CD/DVD burner won't work

  Muergo 14:35 19 Jul 2009

My LG DVD/CD external drive suddenly won't work.

Device Manager shows it is installed but says it is unplugged Error code 41.
I have changed the cable to a new, short Belkin High speed one, and tried on same and different USB port.

Is there anything I have overlooked, or is it a claim under warranty?

  Fruit Bat /\0/\ 14:41 19 Jul 2009

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41
Try this if the optical drives are not appearing in My Computer or Device Manager.
(This is sometimes caused by the removal of Roxio or other writing software.)
click here
Download and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect.
This utility is only intended for Windows® XP, but also appears to work for Vista.
You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.
click here works for vista or XP

Run regedit and navigate to registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}.
Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.
Highlight each one in turn, right click and delete them.
Close regedit and restart the computer.
If in doubt make a restore point before making changes.

click here

  Stuartli 14:49 19 Jul 2009

Try first Uninstalling the optical drive in Device Manager and then Rebooting.

  Muergo 18:06 21 Jul 2009

I tried three of the solutions, but still can't get either drive to work, original equipment was still working, but now both of them are not.
Have tried deleting programs and hoped that starting from scratch the Plug And Play would work, but no.

Device manager says do I want to uninstall! says windows has installed the driver but cannot find the hardware.
I have unplugged it, rebooted, plugged it back in, but nothing happens, I also changed ports again.

Last resort I will try the regedit route, but forgotten how to get into it.

  woodchip 18:38 21 Jul 2009

Try turning Mains Electric off to Comp if Laptop also remove the battery, then hold the start button in for 30 seconds. after connect as normal and retry Hardware

  Muergo 11:35 24 Jul 2009

Finally have external drive recognised and working.
The regedit route from fruitbat (musician?) did the trick, by following his route to the letter I reset the filters and all OK but still don't understand what and how I did it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?