CD Writer Buggered? Driving me insane

  MFKR78 14:48 13 Jan 2005

Ever since I had this PC my standard CD writer has performed poorly, after making literally loads of drinks coasters I switched to Rewritable discs instead and have at least managed to get some discs burnt.

But anyway a while back the drive just stopped working, it even stopped playing normal discs as anytime you put a disc in (anything, game, music, blank) it just jams up and wont read then takes years to get it to open and get the cd back out, it also makes a load of horrible noise when trying to read.

So until today I give up on it, today I had been in my PC cleaning it all up and lo and behold the drive suddenly seems to work.....until I access Nero and try making a CD again, Now the drive is back reading discs in normal time and sounding smooth as it should but now when I click to make a cd it fails immediately saying "medium speed error", I also tried erasing a RWCD and it starts...then flies through the process and says "medium speed error" again before ejecting the disc.

Can anyone help please? Is it stuffed or what, it's been a piece of junk since the beginning.

  €dstowe 14:53 13 Jan 2005

If your computer has been "a piece of junk since the beginning" you ought to have sent it back from whence it came and got it fixed. The consumer laws in this country are decidedly on your (our) side and you had a right to receive a working product.

How long have you had this machine? It may not be too late to get something done about it by your supplier.

  Dennis1 15:08 13 Jan 2005

I've just had the exact same problem with cd writer, It turned out to be the sonic softwrare I was using I reinstalled it and it's now working fine.

  Ceemar 15:31 13 Jan 2005

Go to the CD makers website and check for updates; ie: firmware flash, driver etc. Also go to Ahead Nero and check CD compatability.
Hope this helps.

  Stuartli 15:45 13 Jan 2005

Therein may lie the clue - loose or disturbed leads or cables to/from the drive to the motherboard.

Whilst "cleaning up" your PC you may have been pushing/checking various leads or cables for tightness.

Try checking all the leads again for firm fitting, uninstall the drive from Device Manager and then reboot.

Windows will reinstall the drive and the basic Windows CDROM driver (all that is required) and, hopefully, it will be working properly.

It is also well worth updating to the latest version of whatever sample of Nero you have from the website.

  Stuartli 15:47 13 Jan 2005

Installing firmware should only be done as a very last resort - there are very few occasions when it is required for a rewriter as the burning program, such as Nero, is regularly updated to cater for the latest rewriter models.

Also getting a firmware update wrong can lead to the drive being fit only for the dustbin.

  Modo 16:41 13 Jan 2005
  DeejaySatan 16:46 13 Jan 2005

My CD-RW drive registers in MyComputer and can be opened with thbe "Eject" command but it doesn't read any kind of disk inside of it.

  MFKR78 17:06 13 Jan 2005

That isnt the same prob, My drive USED to not read discs but now it will again. I'm just getting the speed error when trying to erase or burn discs.

I've tried different discs and speeds but its still the same. Before I opened up my PC it had stopped reading discs but after cleaning it out (and I havent touched anything or disconnected anything) its come to life again, only now it only reads and plays discs but wont burn or erase them.

Oh and when I said about it always being poor, it has but I mean the writer alone not the whole comp, I never sent it back as originally I thought I hadnt figured out the software yet and I did manage to get it working for so long after, now it is out of warranty and I realise its just been a joke, I managed to get a few discs out over a short space of time but the rest of the time its either failed 60-70% of the time or packed up like now.

  MFKR78 17:34 13 Jan 2005

Now ive got "power calibration error" and a weird noise when it tried to read the disc

  spuds 18:32 13 Jan 2005

Its obvious that you have a faulty unit.If its still under warranty then go back to the supplier or manufacturer. Otherwise have a look at the selection Ebuyer or one of the other supply companies have on offer, and get it replaced.When things start and stop making funny noises at random, then it is a time for a change.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?