CD-ROM Drive and problem 0x80000012 - help, please

  Kumran 16:04 05 Oct 2004

I run an Evesham PC under Windows Me with a Samsung CD-R/RW SW216-B drive. I use Roxio Easy CD 5, with which I have written CDs without problems for many months.

Recently, however, if I insert a CD, and then open Windows Explorer and try to eject it by right-clicking on the drive and selecting the 'Eject' option, I am returned a message box telling me that the CD is being written to. In full it says:

"Unable to lock the volume. 08x0000012 ..." and that Explorer (or something else) is writing to the drive.

This occurs despite the fact I have done no explicit file reading / writing to the CD.
I also get the same message if, after starting Windows Explorer and clicking on the drive, I try to eject the CD via the drive button. However, I can eject the CD using the drive button if I have not used Explorer; in other words, the problem arises after I've made Windows Explorer 'aware' of the CD. Once the problem has arisen I can only eject the CD by rebooting.

I don't know if it's related, but I also have problems defragmenting the hard disk from the same time, again as it appears that something is writing to the disk. As far as I can see, nothing is writing anything, and I've tried closing as many processes as possible via the CTRL-ALT-DEL facility. No luck.

Any (polite) suggestions, anyone?


  chugby 20:00 05 Oct 2004

have you updated firmware recently, this can cause eject problems. Have you got DirectCD

  Mr Beaujangles 20:41 05 Oct 2004

this is from the windows site:

Error Message "Windows Cannot Defragment This Drive now Because It Has Been Locked by a Disk Utility" When Using Disk Defragmenter
Applies To
This article was previously published under Q286810
When you attempt to run the Disk Defragmenter tool in Microsoft Windows Millennium Edition (Me), you may receive the following error message:

Windows cannot defragment this drive now because it has been locked by a disk utility. Quit any utilities that may have locked this drive, and then try defragmenting the drive again. ID No. DEFRAG00105
NOTE: This behavior can occur whether you start Windows Me in Safe mode or Normal mode.
This behavior can occur if you have the Speed Disk utility from Norton System Works 2000 installed on your system. This utility, if running in the background, blocks the use of the Disk Defragmenter tool.

This error can also occur if the file allocation table (FAT) table is damaged.
To resolve this behavior, if you have System Works, you must quit the Speed Disk utility and restart the Disk Defragmenter tool.

To repair the file allocation table, follow these steps:

Restart your computer in DOS using the Windows Me Emergency Boot Disk (EBD).
At the command prompt type scandisk, and then press ENTER.
The following message appears:
The file allocation table FATs on the disk drive do not match. Scandisk has determined that copy 1 is the best copy. If you choose fix it, scandisk will replace copy 2 of FAT with copy 1.

Press Y to anwser Yes to the message.
Scandisk will replace your damaged FAT with the undamaged copy 1 of the FAT.
After Scandisk finishes repairing your hard disk, remove the Start up disk, and then restart your computer.
When Norton System Works 2000 has just been installed, the preceding behavior does not occur. When Speed Disk runs, however, the preceding behavior occurs.

The reverse situation (the Disk Defragmenter tool running in the background) can block the use of the Speed Disk utility. When you attempt to run the Speed Disk utility, you may receive the following error message:

Speed Disk: Unable to operate on drive C because it is in use by unknown disk utility. Please close unknown disk utility to operate on drive C.

Either of the preceding situations can also result from the overlap of scheduled tasks.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

286263 List of Articles About the Disk Defragmentor Tool

259155 Norton SystemWorks 2000 Is Not Compatible with Windows Me

The information in this article applies to:
Microsoft Windows Millennium Edition

Let us know how you get on.

  Kumran 18:47 06 Oct 2004

Thanks to both (Messers Chugby and Beaujangles). DirectCD is installed as part of the Roxio software I mentioned. The only things I recall doing with at around the time the problem started are installing (i) F-Secure 2004, and (ii) I put in a USB2 PCI card. I'd be surprised if the anti-virus software was a problem, as so many people must be using it, but certainly after installing the hardware the PC start-up has taken longer. I also have Norton SystemWorks 2002 (without installing the anti-virus bit) but this was also the case during the period before I had the problem. Yes, I know the obvious thing to do is to take out the USB2 card, but I wanted to ask around before doing so (but I will try it if there's no simpler solution).

  chugby 20:33 06 Oct 2004

I also have NSW and tried a trial version of F-Secure this year, found out that there is a conflict between the two and had to turn off F-Secure when using the NSW utilities (incl defrag)
to enable NSW to work.

Mentioned DirectCD as known to cause problems
(along with Nero's INCD).

Wonder whether the installation of the F-Secure
not gone well, is it possible to go back to a
System Restore point and do this again. If not
try reinstalling (backup incl registry first just in case.) Make sure any previous version deleted.

For troubleshooting USB try
click here

Could check firmware for drives uptodate also
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?