Is this caused by a virus?

  Shanks 13:44 06 Apr 2003

Hi all, a friend has got a machine running Win98. All was fine yesterday but today it will not boot up. It gets about halfway through the process then locks. We have tried booting into safe mode but again, it locks about halfway through. After trying 'step by step', it starts scandisk (because of failed start) gets to 20% then stops and freezes. We have managed to get to the command prompt only, but interestingly if you try running the Dir command it says:

Volume in drive C is MAIN
Volume serial Number is 183D-1Ae6
Directory of Drive C:\ File Not Found

It is the last bit that concerned me, and if you then change directory to any of subdirectories you can run the Dir command without a problem.

Is this hard drive failure or some sort of (MBR posibly) virus?


  Lozzy 13:56 06 Apr 2003

Since its Win 98 stry using a startup disk/floppy..


If you think its a virus if your using Norton AV try the recovery floppies..

  woodchip 14:06 06 Apr 2003

Use startup floppy and at the A:\> type FDISK/MBR and press enter

  Shanks 14:28 06 Apr 2003

Cheers Lozzy, I've got the floppy and will try that but after it loads to the floppy ... then what? Unfortunately I don't have Norton AV.

Woodchip, Thanks for that, If I do this will it affect the data already on the hard drive?

Cheers for the help

  woodchip 14:36 06 Apr 2003

No it will not affect files it will just restore the Master Boot Record so you can access your drive OK

  woodchip 14:38 06 Apr 2003

PS it sound very much like a Virus, so you can also if you made a Anti-Virus boot disc when you installed AV start with the AV boot disc to check it

  Shanks 21:57 06 Apr 2003

OK, now I've got my hands on the offending PC and I'm now even more confused. I don't have Norton but managed to get AVG to run a complete scan in DOS and nothing was reported. (it was updated last week)

It does keep trying to boot but sticks every time. It stops to run Scandisk (because it wasn't shut down properly) and manages to get to 22% then just stops progressing any further.

I can now do a DIR command of the c drive and copy some files from it to the 'a' drive. There are also four folders called NUL1, Nul2, Nul3, and Nul4 listed but I cant access them in any way and there also appears to be a number of folders missing.

Any suggestions...


  woodchip 22:07 06 Apr 2003

Put the win98 disc in and reinstall over itself

  Shanks 22:13 06 Apr 2003

Thanks Woodchip,

Unfortunately I tried that and the first thing the install routine does is try and run scandisk. This locks at 22% and we're back to square 1.

I happen to know that the win98 setup fils are all on the hard drive - is there a way to run sfc from dos? Would this even help?


  woodchip 22:20 06 Apr 2003

It's not overheating is it, take the cover off and have a look at the cpu fan also try starting the comp with a desk fan pointing into the comp

  Shanks 22:26 06 Apr 2003

I hadn't thought of that Woodchip. Could that cause file corruption on the hard drive? Sadly my better half will go ballistic if I start to dismantle the thing and fire up all my desk fans at this time. (She moans about the noise from the keyboard!!) I will try in the morning and post back.

Cheers for all the help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?