Catalyst control

  Thereferee21 18:20 19 Oct 2011
Locked

I have just got a message saying Catalyst control centre Host application has stopped working.

How do i put this right?

  gengiscant 18:40 19 Oct 2011

Go to ATI and update your graphics card driver which will also repair the catalyst control centre.

  Thereferee21 18:51 19 Oct 2011

Can you tell me what ATI is please.

  Forum Editor 19:00 19 Oct 2011

ATI is the name of the company that made your computer's graphics card.

  john bunyan 19:10 19 Oct 2011

If on W7, click on start, in box type device manager. When it opens select display adapter, then on your ATI graphics card , right click and select update driver.

  gengiscant 19:40 19 Oct 2011

ATI. Go here and follow the prompts for your driver of your graphics card.

  Thereferee21 19:02 20 Oct 2011

I did what you said and it still tells me that the Catalyst control centre host application has stopped working.

  gengiscant 19:27 20 Oct 2011

You did what who said? Me or John Bunyan, if it was me ,did you uninstall the old driver first. If not try that then restart your PC then reinstall. Do not worry if your screen looks odd after restart.

  Thereferee21 19:46 21 Oct 2011

Hi Gengis,

I missed one of your messages concerning the download, I tried it today and it tells me my card is not supported and i have to contact my notebook supplier to get a download.

I also uninstalled the old driver then reinstalled it, but i get the same message that the Cat cont host is still not working. If i format the hard drive will that resolve the problem.

Thanks for your help

Ian

  gengiscant 05:51 22 Oct 2011

If you anre going to go the format/reinstall route then hopefully you have either a factory reset disk or some other method of reverting to your laptops original setup. Or do you have a Windows disk and a motherboard disk which will have all e drivers you need.

Have you looked for a graphics card driver at your laptop makers website? If you care to post your make/model of your laptop then I'll have a look for you. Format and reinstallmis a bit of an overkill for your problem and it really is a pain involving a lot of time and effort on your part.

  Thereferee21 16:11 22 Oct 2011

Hi again Gengis,

It is a Toshiba Sattelite A300.

Thanks

Ian

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?