Catalyst Contorl Centre

  Darkhisagi 11:39 06 Sep 2011


Recently, my Catalyst Contorl Centre has stop working and each time I boot up or tries to open up the control centre, an error message like this pops up:

Cataylst Control Centre:host APplication has stopped working Windows is searching for soultion

This happened after I somehow got an adware online. And Google Search functions returned to normal this morning after my Panda Antivirus detected 2 Adware Programs in my App Data Roaming files.

I think a registry cleaner can sort this out, but dunno which one to try/trust. Also, my graphics card has not been overclocked in the contorl centre either.

Thanks very much!

  PSF 12:13 06 Sep 2011

It would be best to un-install and re-install your drivers, Have a look at the link for removing and installing new drivers.

  Darkhisagi 12:44 06 Sep 2011


Thankss fr your reply. I have tried unistalling the Catalyst Contorl Centre, but in Unistall Programs, al it say's is Repair.

And when I tried to click repair/repair it, it says 'The feature your trying to use is a network resource and is unviliable?'

So I can't repair it nor unistall it, can you help me please?

Many Thanks

  PSF 13:05 06 Sep 2011

You could try running this first

Or download and run the Windows Installation clean up Utility, I have used this a few times when ptograms will not un-install.

  Darkhisagi 13:12 06 Sep 2011


PSF< i have managed to unistall Catalyst Contorl Centre by unistalling all ATI programs using their Install manager. However,, once I downloaded the Catalyst Contorl Centre again, the same error message pops up?

Many Thanks

  PSF 16:54 06 Sep 2011

Have you run Windows update to make sure that your Microsoft .net framework and Microsoft Visual C++ is upto date. I have had that before with ATI drivers. In the end I removed all .net and C++ and then rebooted and then re-run Windows update to re-install them. reboot after updates as well.

When you uninstalled the drivers did you shut down and then restart?

Don't let Windows install the drivers cancel the install and then run the installation from where you have downloaded the new drivers. It is best to use drivers for graphics cards direct from ATI and not use the Microsoft drivers. You get less problems using ATI drivers.

  Darkhisagi 18:57 06 Sep 2011


I'm sorry, btu I dont understand how to do all thoe things, Im not an expert at these things, please can you give me simple instructions so i can follow?

Also, after I unistall it, I didnt reboot nor after the installation is complete. However, just when the installation is completed, the error popped up on itself???


  PSF 00:08 07 Sep 2011

First have you downloaded the latest drivers for your graphics card? If not go to and download driver for you card, make sure you download the correct version for your operating system. eg Xp or Win 7 32 or 64.

I take it by the fault described you have Win 7. If you do click Start>>>> control panel>>>>>> Programs and features>>>> then uninstal the Microsoft .net and microsoft visual C++ programs, re-start the computer and the run Windows update which will re-install the .net and C++ programs, once installed run windows update again for the updates for .Net, you may have to do this a couple of times as there are a few updates that have to be installed in order.

When that is all upto date remove the ATI programs as you did before.

Restart the computer, when the 'new hardware program' starts cancel it and ignore the problem message about the driver.

Then install the drivers from where you downloaded them. Once installed you will have to restart to finish off the installation. Hopefully that should resolve your problem....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)