Carder reader will not open on auto. Vista Home

  badgermansix 23:54 01 Jan 2010
Locked

Vista Home Premium

My son has a card reader in his Laptop, which will not open on Auto when he inserts a card, is there any way that he can change this please?
If he goes to Control Panel, right clicks on the carde reader while it has a card inserted, the option to open Auto is not there.
He says that nhis friends does?

tia

  Fruit Bat /\0/\ 11:28 02 Jan 2010

Ensure that Shell Hardware Detection service is running

Type “service.msc” in Start Search to run Services console. Locate Shell Hardware Detection, and ensure that the “Service Status” is Running, and “Startup Type” is Automatic. If not, start the service and change the Startup Type setting accordingly.

Ensure that CD-ROM AutoRun is not disabled in registry

For users facing AutoRun/AutoPlay doesn’t work when insert a disc into optical drive, run Registry Editor (regedit), and navigate to the following registry subkey:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

Locate the AutoRun registry value in the right pane, and check that the value data for AutoRun is set as 1 (one), which is enabled. If it is 0 (zero), which mean disabled CD-ROM or DVD-ROM drive AutoRun process, re-enable the AutoRun by changing the value to 1.

  Fruit Bat /\0/\ 11:29 02 Jan 2010

Ensure that correct NoDriveTypeAutoRun and/or NoDriveAutoRun policy value is set

NoDriveTypeAutoRun registry key is used by Group Policy to configure whether to disable the Autoplay feature on all drives of the type specified. To check this setting, run Registry Editor (regedit), and navigate to the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

or (note that above registry value, if exists, will always supersede the below user-specific key),

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Locate the NoDriveTypeAutoRun registry entry on the right pane. The registry key is in DWORD hexadecimal value, which each bit determines which type of drive to disable or enable AutoPlay feature. There are many possible value for NoDriveTypeAutoRun, some possible wrong value that disable AutoPlay are:

0×000000B5 (181) disable AutoRun on CD-ROM drives, plus default unknown drive, removable drive (meant for floppy or ZIP), network drive and reserved drive type.

0×000000FF (255) disable AutoRun/AutoPlay on all drive types.

The best bet is to set NoDriveTypeAutoRun to default value as set by Windows Vista, which is 0×00000091 (hexadecimal) or 145 (decimal). Previous Windows version such as XP uses 0×00000095 (hexadecimal) or 149 (decimal). To enable AutoPlay on all drive types, set NoDriveTypeAutoRun to 0 (zero) or 0×00000080 (128) which only disable AutoPlay on unknown reserved file type.

NoDriveAutoRun registry key, which stored at the same registry location, meanwhile determine whether a particular connected drive should run AutoPlay function or not. When AutoRun is enabled on the drive, media is automatically started when it is inserted in the drive.

By default, Windows Vista does not add any NoDriveAutoRun registry subkey. And you probably don’t want to block any drive from AutoPlay too. So remove and delete all NoDriveAutoRun key in the registry.

Uninstall conflict software

Some software application, especially disc imaging or image editing program such as Nero, PowerISO, MagicISO, and even some other programs such as Rhapsody and various VMWare virtualization products such as VMWare Server and VMWare Workstation.

If you’re facing the drive won’t Auto Play or Auto Run issue after installing certain software, try to uninstall the software to see if it fixes the problem. Better still if it’s possible to roll back the system using System Restore to earlier Restore Point when the software is not yet installed.

  mooly 12:42 02 Jan 2010

Some laptops have the facility to turn off the card reader etc to save power... but it's done via a manufacturer specific utility that is installed along with Windows... just a thought.

  badgermansix 23:16 02 Jan 2010

mooly, thank you for your input, I took the advice of.....

Fruit Bat /\0/\...and thank you very much also,
we did try and type in "service.msc" but got item not found.
We went to the registry, followed the paths you suggested, and things appeard to be o.k.

But.. "By default, Windows Vista does not add any NoDriveAutoRun registry subkey. And you probably don’t want to block any drive from AutoPlay too. So remove and delete all NoDriveAutoRun key in the registry." we deleted and tried that, and got the result we hoped for, so, once again, thanks very much.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache