Can't write memory stick

  Pineman100 10:47 09 Nov 2006
Locked

Running Windows XP SP2 Home

When I insert a memory stick into a USB port, the computer recognises it with the usual 'bing bong' and it shows up on 'My Computer' as 'Memory Stick Drive: E'.

However, when I try to save files to the memory stick, a window pops up saying 'Insert disk into Drive: E', and the cursor stays on egg-timer. This happens if I try the 'save as' procedure, or the drag-and-drop. I have tried two different memory sticks, and it happens with both. The write-protect switch on the memory stick is off.

Anyone got any ideas please?

  Sethhaniel 11:00 09 Nov 2006

and check properties ???

ie read only etc.

  The Brigadier 11:10 09 Nov 2006

Is it formatted?

  vinnyT 11:18 09 Nov 2006

Have they ever worked?

Are you able to try them on a diff. pc?

Have you tried copying to them with the write-protect in the on position. Some have been known to be labeled incorrectly.

  Pineman100 17:58 09 Nov 2006

Both sticks work fine in another computer.

Brigadier - how do I find out whether the stick has been formatted sir, please sir?

Vinny - I'll try with the switch the other way. Thanks for the idea.

  Fruit Bat /\0/\ 19:03 09 Nov 2006

If they work in another PC then they have alredy been formatted.

In My computer right click the E drive select properties, look at the General tab it should say FAT32.

you could always try to Refresh USB Ports.
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Pineman100 19:15 09 Nov 2006

Thanks Fruit Bat. I'll try that.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017