Can’t reinstall scanner

  Onizuka 14:52 27 Jan 2008

My 5 year old Epson Perfection 1260 Photo scanner worked perfectly with my old PC running Windows XP. However, my new Dell XPS 420 running Windows Vista refuses to install it. Device Manager shows Epson Scanner under Other Devices and I downloaded the Epson Twain5 driver for Vista from Epson’s website. However, Windows said there was no driver software in the file.
I’ve tried uninstalling and reinstalling the scanner and its software several times without success and I’ve run out of ideas. Can anyone help please.

  Jim_F 15:16 27 Jan 2008

Download this and see how you get on:

click here

Assuming this is Vista 23 bit - 64 bit and scanners are bad news :(

  Jim_F 15:20 27 Jan 2008

If you already have the file I linked you may need to let it install itself and then let Windows find it on your HD - its just a windows thing !

  Onizuka 15:35 27 Jan 2008

Thanks. The file installed itself in C:EPSON\epson12242_twain5_driver_571a and I directed Windows to it. However, as I originally said, Windows said there was no driver software in the file.

  Jim_F 15:44 28 Jan 2008

Sorry - you need to run 'setup' in that directory.

This should load the driver filed although you will need to give it admin priviledges via the UAC prompt.

  Onizuka 16:30 28 Jan 2008

I'm afraid I'm not quite technical enough to follow you. Could you please explain in beginner's terms what you mean by running "setup" in that directory and how I give it admin privileges.

  Jim_F 01:08 29 Jan 2008

Hi Onizuka

Sorry I lost you on that one.

In the directory:
there should be a file called 'setup.exe'

Just double click on that and it should install the driver.

On the way it will need admin priviledges - the screen will go dark and you will be asked to approve this (if Vista security is enabled).

To explain - some drivers come in a form that Windows can recognise aand install itself. Others - like these - insist on using their own setup program.

  Onizuka 12:35 29 Jan 2008

No need for apologies. My brain had frozen after all the fruitless hours getting nowhere and when I saw your subsequent detailed explanation I couldn’t believe that I hadn’t been able to follow your earlier post in the first place. I’m still getting used to Vista and your reference to UAC didn’t immediately register.

However, I’m afraid to report that it still doesn’t work. On the off chance that the culprit might be a faulty USB port I swapped it with the printer. Windows detected a new hardware device and ran through the Driver Software Installation process. When that failed I ran “setup.exe” as you advised (having approved it via the UAC) and tried both the “Modify” and “Repair” options in the “EPSON TWAIN 5 – InstallShield Wizard”. The EPSON Smart Panel opens every time but when I click on the options “Scan to File” or “Scan for Creativity” a message box appears saying “Unable to access the scanner because it is not ready or another application is using it. Please make sure that the scanner is on and connected to your computer, or close all scanning applications.” If I click on to “Copy” the message box says “The scanner cannot be detected. Please make sure the scanner is connected properly and press Retry.”

The printer works in the USB port that I’d first connected the scanner to and there is power going to the scanner (its light is on), so I’m rapidly being forced to the conclusion that the scanner itself may be faulty. There must surely be some Forum members who have successfully reinstalled an Epson Perfection 1260 Photo scanner with Windows Vista Home Premium and if none of them has had any problems it would suggest that my scanner is indeed faulty. Is there any way of checking the scanner itself?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?