Cant recognise my Hard Drive in Enclosure

  TicTacToc 21:35 21 Feb 2006

Ok, so I have got my corrupt hard drive out of my laptop and bought a hard drive enclosure.

However, (my enclosure is driverless) Windows isnt recognising the drive under My Computer or anywhere, Im guessing as it is corrupted, how do I get it to recognise the driver for use with data recovery software?


  jimv7 21:39 21 Feb 2006

If the drive is faulty it might not be seen, connect it in place of the dvd/cdrw and then see if windows can recognise it.

If it does then transfer wanted files across.

  jimv7 21:41 21 Feb 2006

sorry, just saw laptop.

If there are two usb connections from the drive enclosure, plug both of them in, the faulty drive might not be getting enough power with only 1 connection.

  Softstag 00:32 23 Feb 2006

You don't say what OS you are using. If you are using Windows 98 then you will need to install drivers, as unlike XP it does not have them installed by default. Microsoft did not create drivers for 98, but you can get generic USB mass storage drivers if you click here

  jack 08:28 23 Feb 2006

Your meaning is not clear to me.
You said you have taken a 'corrupt' hard drive out of your laptop.
What did you put in its place?
You have now put said corrupt drive in an enclosure,
but cannot get it to read.

A lot more detail is required here.
I assume you did put a new drive into the the machine, format it and reload the operating sysytem.
If so what operating system.

  TicTacToc 20:37 24 Feb 2006

Ok, sorry for not adding enough detail first time around. I still havent succeeded.

The hard drive is from an HP Pavilion ze4325us. In November I was using the laptop when suddenly I got a blue screen. I didnt read it very well but I vaguely remember a config on it. I tried to reboot and it wouldnt go past the windows loading screen. Quite soon afterwards it was too jammy and unstable to even get to that screen or get into setup. A friend though it sounded like it was my hard drive. Knowing that I was just about to start backing up with some slow disks and that I didnt have all the data I looked into the hard drive recovery stations – all were too expensive at the time so I left it a bit.

My computer knowledge has expanded a lot since then and I have recently built a new computer. I learnt how it was possible to use an enclosure/cable to attach it to the desktop.

I unscrewed all my laptop and took it open. I kinda found out that I could have taken the hard drive out easiler at the beginning although Im not sure. The hard drive as blue on the bottom and a Toshiba one.

I went out to shops to look for a good hard drive enclosure (they didnt seem much more expensive than the cables and they seemed simpled to use – maybe I was wrong.) I couldnt find any, and they were more expensive than eBay.

I found one that looked good on eBay so bought it:
click here

When it arrived I clipped the connecter onto the hard drive (one or two contacts didnt seem perfectly straight) and it doesnt seem to clip on perfectly but it seems to be ok.

I started trying to put it into the enclosure but it would not fit as it had the metal surroundings still from the laptop which needed to be taken off. I realised that Im not taking it anywhere, I wont touch it too often so I could just not include the enclosure which offers just protection.

I plugged the hard drive and connector into my computer and booted it. The red light came on on the connector showing the hard drive was being red. It seemed to make a slightly funny working sound that was almost like it was struggling to read the data. The light went green showing it was ready and the hard drive was inserted properly. I went into 'My Computer' to see if it was there. It wasnt. I couldnt (not sure where else to look) find it anywhere else. The hard drive is corrupt, it should still be recognized? What if the sound it is making means it is physically damaged, does that still mean it would be found? When it is found, will I click on it and it just say 'the data from this cd can not be read.'

I looked at the small page of instructions. I am running Windows Xp Home. It instructed me to add new hardware. It came with a small disc with drivers on that normally only need to be used with windows xp. When in 'add hardware' I get to the stage where it says 'pick the hardware category you want'. The instructions says 'click other hardware devices' but it is not there so I cant progress with that.

The enclosure came with a usb cable that had 2 on the end of it, so I tried putting both into my usb ports for extra 'power' but nothing changed. The lights still came on fine but it didnt see it or anything.

The other troubleshooting option was something to do with setting my motherboard (A8n-Sli Deluxe) to register Usb devices. Im not sure how to do this, but I think by the fact I use a mouse and a keyboard e.t.c that is fine.

So I am stumped, and really need some help in getting the enclosure to be recognised.

Thanks very much!

  woodchip 20:54 24 Feb 2006

Go into BIOS when starting your computer, on screen it should say something like to enter setup press Del=Delete key look for USB and enable all USB save settings and exit BIOS. Computer will restart. Now check in Windows Explorer for the Drive

  Fruit Bat /\0/\ 21:27 24 Feb 2006

Error was probably
Windows XP could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM32\CONFIG\SYSTEM
Windows XP could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM32\CONFIG\SOFTWARE
Stop: c0000218 {Registry File Failure} The registry cannot load the hive (file): \SystemRoot\System32\Config\SOFTWARE or its log or alternate

Put back in laptop and click here

  TicTacToc 22:44 24 Feb 2006

woodchip all my usb settings were enabled already so that didnt help ..

fruitbat. . .. err im not sure my laptop is in a well enough state in relation to its physical state currently, and if its failed wont I need to buy a new laptop hard drive. . .?

Has my data all been deleted you think, but the hard drives fine? I would have thought the hard drive couldnt be used any more. . .

All other ideas welcome :)

  woodchip 19:39 25 Feb 2006

What I think the Problem is. Is a Corrupt MBR. If you have a Floppy drive in the Laptop you could start the computer with the Hard Drive in and a Win98se boot floppy. and at A:\> type FDISK /MBR press enter

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?