Can't get PSP to connect to internet

  ivesy 15:58 15 Sep 2007

I've been on most of the day trying to find out why my PSP won't connect! So any help here would be appreciated.

I have a Dlink DSL G604T wireless router which is WPA security enabled. I have no trouble getting the laptop to connect via the router to the internet but for some reason the PSP refuses to do so!

The instructions I got with it are terrible and assume you will connect first time. The message I get is "the connection to the access point has timed out"

Has this happened to anyone else?

  Strawballs 19:30 15 Sep 2007

I don't know to much about PSP's but one of my son's friends had one when they first came out and I had the same trouble connecting to my WPA network then found out that there was a problem with the PSP at that time for encrypted networks but I thought that they had it sorted now.

  Ashrich 22:32 15 Sep 2007

I think PSP's only do WEP security , try changing to WEP temporarily and see if it makes a difference .


  irishrapter 22:53 15 Sep 2007

Yes the PSP only uses WEP encryption but there was meant to be a firmware update that will enable WPA, but as if yet I have not heard of any success in getting this to work.

  ivesy 10:21 16 Sep 2007

I've just got the PSP on Saturday so I assume since it's the new version it's got the most uptodate firmware. I tried connecting with WAP off and it worked first time, so the problem must be with the level of security. I'll try WEP later but as we keep being told WEP is less secure than WPA. So I'm not to keen on that. thanks for the responses

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?