Can/t get laptop to power up

  jkm2525 15:28 13 May 2006
Locked

Hi , Ive a TOSHIBA TETRA 8000 Laptop , was having problem switching laptop on , now can/t get it to power up . ive got power to the laptop the power light cames on & it is charging the battery . as soon as i touch the power switch the power light flashes but laptop won't start up . Could it be the off / on switch or worse ?
any help would be appreciated . Thanks

  DieSse 18:02 13 May 2006

Unplug, take out the battery, refit and try again.

  jkm2525 19:47 13 May 2006

thanks DieSse tried that ,same problem .

  ade.h 20:36 13 May 2006

Is it still unresponsive when run on the mains lead *only* with no power cell fitted? Likewise, if you let it charge and then try it with only the power cell, is that any better?

  jkm2525 20:51 13 May 2006

yes i've tried both , still the sams . thx

  ade.h 20:54 13 May 2006

Hmmm. Then I suspect that there may have been an internal failure somewhere; perhaps part of the mainboard. Not good news, if that turns out to be the case.

It might be time to have it examined by a good laptop repair specialist or sent to the manufacturer.

  jkm2525 23:18 13 May 2006

thanks ade.h ,will take it to a pc shop tomorow for a estimate .

  ade.h 23:20 13 May 2006

Sit down first! (Might not be cheap, but here's hoping that it's not serious).

  DieSse 00:02 14 May 2006

Unplug, take out the hard drive, refit and try again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?