Can't download files or stream via Belkin router

  Roxer 10:05 12 Mar 2008

We've just installed a Belkin F5D7230-4 wireless router. General surfing is OK, but when we try to download a file (including software updates), or stream a video from YouTube, it stops after a few seconds. It's the same from each of our PCs, whether plugged into the router or wireless.
Yet if we plug any PC directly into the cable modem (an ntl:home 200) all downloading and streaming is fine.
The router isn't running hot. Its firmware is the latest version.
Can anyone help, please?

  jonigiro 10:59 12 Mar 2008


I had the same problem when I purchased the Belkin F5D7230-4 wireless router. I'm not sure but I think it's a problem with updating the firmware I found that it worked fine after I updated the firmware but the problem returned after I had powered down and back up. The solution I found was just to keep trying to update the firmware with router connected using an ethernet cable. it was a bugger of a problem but one that just disappeared after alot of trying different things. My wireless network works fine now. Hope that helps


  setecio 15:12 12 Mar 2008

Not easy to point to a specific thing but you might try adjusting the MTU

click here

  HardenedRocker 07:59 24 Mar 2008

I looked her and this post didn't have anything, but I was messing with my router settings ( and I set it up as an access point and that fixed my streaming/downloading problems completely! Just right now actually... and I registered to tell you. Maybe it will help you out too... I'm excited to finally be able to stream :p hehe. Well, hope this helps...

-Phillip (Novakaine <3)

  Roxer 14:49 24 Mar 2008

Thanks very much jonigiro, setecio and HardenedRocker.
I'll try your advice.

  prasad_matri 04:54 11 Jul 2008

I recently bought a belkin wireless router and the model is same as mentioned in this thread.

I found that when I updated the firmware, the issue was resolved. But when I restarted the router it was back to square one.

For now I am updating the firmware everytime, I stop and start my router.

But thanks for the tip, atleast I had some important attachments to be downloaded from my email.

One thing I noticed before fixing this issue (that is temp'ly ;) ) was that when listening to songs online via REALPLAYER or webpages that uses REALPLAYER, there are no issues.

  Roxer 08:09 13 Jul 2008

Hi prasad_matri.

A firmware update didn't solve my original problem. I tried several things, suggested by other members, and found the problem was solved, but can't point to which might have been the solution!

Occasionally the problem returns, but I solve it by unplugging and replugging the power supply, to reboot it. That didn't solve the problem when I first raised it here, but it appears to work now, so something must have changed for the better!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?