Can't display web pages, Internet Explorer corrupt

  cyberphobic 18:02 28 Oct 2006
Locked

My friend's PC connects to the Internet using a BT Voyager 2100 wireless modem router. This is shown as being connected (confirmed by his ISP) but he is unable to display any web pages - he just gets an egg timer. He has spoken to his ISP's techical team and after trying various ping and telnet tests and resetting winsock they told him that the problem is clearly with Internet Explorer which must be corrupt and needs reinstalling. Is anyone able to confirm whether this is the likely cause of his problem or is there something else it might be?

  anskyber 18:07 28 Oct 2006

Try a repairclick here

  anskyber 18:08 28 Oct 2006

Ignore that post.

  postie24 18:10 28 Oct 2006

Try running a virus scan in safe mode.

  anskyber 18:12 28 Oct 2006

Have you tried system restore?

  cyberphobic 18:33 28 Oct 2006

Have system restored but no luck, had thought of repairing IE, haven't tried scanning in safe mode but will do tomorrow

  postie24 18:54 28 Oct 2006

Good luck

  cyberphobic 20:45 13 Nov 2006

Further to this post, I attempted an Internet Explorer repair which didn't help and then I installed Mozilla Firefox but was unable to view web pages with that either. At that point I gave up as all I could think of was to reinstall Windows which seemed a bit dramatic. Since then my friend has been waiting for a local "expert" to come round and fix the problem. Tonight he turned up, and after a while pronounced that the PC had a virus and he would have to save all the data to CD and then reinstall Windows which would cost £100 approx. He advised them to get Norton Anti Virus (it had Norton when it developed the problem, I removed as it is so intrusive and replaced it with AVG!) I can't say that I'm very convinced by any of this - The PC is clearly connected to the internet (as confirmed by the ISP) and email works fine but no web pages can be displayed. Can anyone offer an explanation as to what the problem could be?

  cyberphobic 23:12 13 Nov 2006

Any ideas anyone?

  skidzy 23:31 13 Nov 2006

You could turn off system restore/reboot and enable system restore,please be aware you will lose any restore points that were availible.

But first download this to disc or flash drive and insert into your friends pc and run. click here

He could also try resetting the web settings via the tools/internet options.

  lotvic 23:39 13 Nov 2006

could the routers firewall be blocking anything?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017