Can't access Defrag

  birdface 21:54 17 Apr 2008
Locked

Hi.Decided to remove SP3 beta to be ready for the full edition coming out on Monday.Tried to run the system defrag and get the message.MMC Cannot open the File C;\Windows\system32\dfrg.msc .Now I don't know if it will automatically come back when I Download SP3 again or whether it may stop the download.Anyone got any ideas.Computer is a lot slower without SP3 so will be glad to get it back on.

  MCE2K5 22:00 17 Apr 2008

Does this help click here

  MCE2K5 22:02 17 Apr 2008

Or this click here

  Earthsea 22:09 17 Apr 2008

From MCE2K5's second link:

Start>Run, and type:

regsvr32 /u msxml3.dll (note the spaces)

then

regsvr32 msxml3.dll

  Earthsea 22:12 17 Apr 2008

Alternatively, use Diskeeper Lite until Monday click here

I use it anyway.

  birdface 22:40 17 Apr 2008

Hi.nothing on MCE2K5 first click here.Tried Earthsea's run and type although both worked still no difference.Will go back to the second click here and have a look.What does Disckeeper lite actually do.

  Earthsea 23:08 17 Apr 2008

Diskeeper Lite just defrags your hard disc. I've used it for years and prefer it to the Windows one.

I don't think it's worth fiddling around with your system since SP3 is just about to be released. Hopefully it'll fix the problem.

  MCE2K5 23:10 17 Apr 2008

"Diskeeper Lite is a short version introduction to full-featured Diskeeper. Diskeeper Lite can only analyze fragmentation levels and run manual defragmentation on one disk volume at a time. All time and money saving Set It and Forget It® scheduling, system management functions and network controls are shown and explained, but rendered inoperative. This tool will show you how easy the full version is to install and operate across any size network . Diskeeper Lite will help everyone in their selection of the right automated defragmentation software for their homes and/or business sites. "

  birdface 00:36 18 Apr 2008

Thanks folk for all your help.I have found a solution but not a fix.At the bottom of the box that popped up it said This may be because you do not have sufficient access rights to the file.I ignored that part as it is my computer and I am signed in as administrator.So as a last resort I started in safe mode using the administrator account and it worked ok on that.Tried it on my account while still in safe mode and it would not work.So unless someone can tell me how to fix that.I will just leave it till SP3 comes on Monday.Then if it still does not work I will use DiscKeeper Lite.So will leave this open till Monday to see if anyone can come up with a repair.As long as I know that I can Access it in safe mode I am not that worried about it just now.Thank you both for your time and help it was appreciated.

  birdface 14:55 18 Apr 2008

Not sufficient access rights.anybody any idea how to fix it.I can only think that is the cause if it lets me access the defrag in safe mode using administrator sign in.

  birdface 11:05 23 Apr 2008

As long as I can run Defrag in Safe mode I will class this as resolved.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans échec ?