Can't access certain websites after enableing WPA

  moon1953 19:47 12 Jan 2009
Locked

I have a Belkin G+ MIMO Modem/router.

When I use the router wired or wireless with no securty everything works well on both my XP laptop and XP desktop.

Problem 1: When I enable WEP128 the laptop connects and continues to work well but the desktop connects and gets an IP address, but can't connect to any websites (I can't even ping the router!)

Problem 2: Gave up on WEP and tried WPA-PSK; both systems connect and many websites work - however some websites on both systems simply won't connect. e.g. pricerunner.co.uk. Also things that need some sort of authentication like iTunes store will not log in.

Any ideas? I've tried all sorts of things and searched the internet high and low for ideas....
Thanks

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?