Can't access admin page

  dagbladet 19:34 20 Dec 2005

My D-link604T has lost its connection. Based on previous advice on these forums I unplugged the router for a couple of minutes and tried again with no luck. I then tried to access the router admin pages on but I am just getting the 'page not found' malarkey. Any ideas folks?

  powerless 19:45 20 Dec 2005

Unless D-link are unique.

  dagbladet 19:48 20 Dec 2005

Thanks powerless but that doesn't work either.

  PaulB2005 20:11 20 Dec 2005

Different brands use different IP Addresses - my Buffalo uses

According to the D-Link 604T it is indeed on this model.

Try powering the router down for 5 minutes and then try again.

  mgmcc 20:27 20 Dec 2005

If, for some reason, the router's DHCP server isn't allocating an IP address to the PC's network adapter, before being able to access the router's "Setup" pages, you will have to configure it manually with an IP address in the same subnet, for example with Subnet Mask

  dagbladet 20:41 20 Dec 2005


I think I know what you're getting at but not sure what to do with the information.

  fishytroll 21:30 20 Dec 2005

Hi, first you should unplug the router for about 1 minute and then try internet explorer, for some odd reason firefox doesn't always do it. this will take you straight to the page you need mate. your ip address is correct as i have the same router.

  mgmcc 22:44 20 Dec 2005

<<< I think I know what you're getting at but not sure what to do with the information >>>

Open a Command Prompt window (in XP go to "Start > Run", type CMD and click OK) and, at the prompt, type:


and press Enter. You will see details of all adapters in the PC. See what IP address you have for the network adapter. If it is in the 192.168.1.x range then the router has allocated an address. If it is in the 169.254.x.x range, the adapter has been unable to get the address and you need to enter it manually.

To allocate an address manually, open the Network Connections folder, right click the Local Area Connection and select Properties. Highlight the entry for "Internet protocol (TCP/IP)" and click the Properties button. In the box that opens, select "Use the following IP address" and enter the address with Subnet Mask

  dagbladet 22:54 20 Dec 2005

Well, the tried and trusted method of switching it off and going for a cup of tea works again. Having checked in the run/cmd/ipconfig the settings are as you describe. BTW do I have to be online to access the admin page at Thanks folks.

  mgmcc 23:01 20 Dec 2005

<<< do I have to be online to access the admin page at >>>


  Woolwell 10:54 21 Dec 2005

I have one of these routers. is correct. How are you connecting to the router? As I understand it you can only access the router through wired connection. What lights are on on the front of the router? You should have Power on, Status flashing, ADSL steady green, WLAN steady green and one of the other 4 lights also steady green.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?