Canon MP 780 AIO + Win 98 Problems

  Nickoftime 10:16 07 Nov 2005

Just bought one of these AIOs. Works fine with my Laptop (XP Home) but causes BSoD (Fatal Exception at 0028:FF0D2CF6) on connection to my PC (Win 98SE). Manual suggests that it requires XP (or 2000) to work with USB 2.0 (which my PC has): manual only mentions Win 98 O/S in connection with USB 1.0 ports. Could this be the problem & if so (how) can I downgrade just one of my ports to USB 1.0 ? Anyone have similar problems with MP780(or any other peripheral) in connection with Win 98SE + USB 2.0 ?

  Splork 10:24 07 Nov 2005

USB 1 and 2 are compatible - it's only the speed that is different. Do you have any other USB devices connected to your desktop PC?

  jack 10:52 07 Nov 2005

98 needs USB drivers- do a search in the window above use 98- USB as keywords- if the problem persists, then a USB card reader -which comes supplied with multi O/S driver may be the way out or down load on the the lappie and into a pen drive or burn a disk to get to PC

  Nickoftime 11:16 07 Nov 2005

Thanks, people...but:

Splork: yes, I've confirmed that other USB (1.0 & 2.0) devices work OK but I first tried connecting the MP780 without any other devices connected to avoid conflicts.
Jack: I loaded the Win 98 USB 2.0 Drivers that came with the motherboard CD before loading the MP780 Drivers and S/W and then making the physical connection.

  Splork 11:19 07 Nov 2005

Have you got a powered USB hub you can plug the Canon into ? Would rule out power shortages, even bearing in mind it works fine with your laptop.

  Nickoftime 22:46 07 Nov 2005

Thanks again, Splork. I tried this but got the same failure. I also tried connecting using a USB 1.0 cable thinking maybe it was the higher speed my PC couldn't cope with but that still lead to the same BSoD failure.

  Splork 22:53 07 Nov 2005

How far does your PC get if you plug the Canon in before you switch the whole lot on?

  Nickoftime 23:33 07 Nov 2005

Splork: Initially when I tried this it went through the process of identifying new hardware (i.e. the MP 780) & looking for & loading the S/W. At the end of this process I got the BSoD. Subsequently it crashes just as it finishes booting up (Desktop icons showing etc).

  Splork 00:56 08 Nov 2005

Next thing to try is switching off peripherals/ports in BIOS in case something is conflicting. Try something like Filemon from click here to monitor which files are loaded when you plug the printer in - one of them may be the trigger.

  jack 08:27 08 Nov 2005

There is a grave danger with all of these types of problems of getting in too deep, and then getting lost in the maze.
Win 98 needs USB drivers, and is still very iffy.
Win 98SE is better.
Using the kit you have, the best route by far is work the camera with the lappie.
transfer images from lappie to desktop.
get a card reader with an all systems driver disk
and plug that to the desk top.

  Nickoftime 10:31 13 Nov 2005

Thanks again-been away for a bit hence my lack of response. I've now done the following: re-installed Win98SE (in case there was any S/W 'clutter' causing a problem)and unistallled the Asus M'Board USB 2.0 driver. This has resulted in the Canon no longer crashing the PC on connection and the device working OK in both Scanner and Fax modes. However trying to print yields messages like "Printer not responsing" & "Data Error - cyclic redundancy check" and advice to onstall the correct pronter driver. However going into Device Manager, Properties etc it says correct driver is installed. Under Properties the MP780 Printer Icon shows "MPUSBPRN02 (Unknown local port)" under 'Print to following port' (the only other related Port option is "MPUSBPRN01 (Canon MP780 FAX:5095E5). Any ideas please ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?