Canon LBP-1120 and Vista

  Neill 21:21 04 May 2007

New PC with Vista Home Premium (32 bit) and both the Cannon LBP-1120 laser printer and the LiDE50 scanner refuse to work.
Downloaded both software from Cannon and the printer is there supposedly working OK in Device Manager. Scanner says it isn't working.
Print from Word gets Error - printing under Status which then disappears.
Cannon say they will ring back next week as they don't know why! Any thoughts? Thanks

  Ashrich 00:09 05 May 2007

Have you made the printer the default printer for Vista , I think that when you have word loaded the printing properties default to Microsoft Office Document Image Writer and not your installed printer . Are you using driver for the scanner , if not click here for that version , this is from the Australian Canon site , this is where I got the drivers for my N670u which works well under Vista .


  Neill 08:46 05 May 2007

The printer is already the default and still no luck. The scanner link you gave doesn't work but I'll try going to the Australian web site. Thanks

  Neill 18:35 07 May 2007

No luck with the Australian site. Same result.

Just tried putting the USB cable into the front USB port and now have the message "The printer is connected to a port of an unsupported type".
Still no reply from Cannon but can anyone help with this extra bit of information? Thanks

  Neill 18:49 07 May 2007

Sorted. Printer port in Properties was set to LPT1. Changed to USB Virtual printer port and it works. Just the scanner to sort out now.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?