Cannot upload revised page to Virgin Net freespace

  Charlie Babbage 21:36 11 Sep 2006
Locked

I have a problem uploading a new page called ‘newworship.htm’ from my local drive to Virgin Net freespace click here using Cute FTP. I have tried contacting Virgin Net but, so far, have not had a reply. If anyone here can help, that would be great.

To upload a file in Cute, you drag the filename from the Local files pane on the left to the Remote files pane on the right. When I try to do this, I get an error message headed 'File Transfer Log' that reads ‘The filename provided is not being accepted by the server. Check for invalid characters and try again.’ However, when I click the ‘Details’ button in the error message box the top line reads ‘550 /./docs/newworship.htm: No such file or directory’

Under that, there are the following details, 'STATUS' being blue print, 'COMMAND' being green print and 'ERROR' being a colour difficult to descibe - reddish!!

STATUS:> Requested action not taken (e.g., file or directory not found, no access)

COMMAND:> CWD /./docs
250 CWD command successful

STATUS:> PWD skipped. Current folder "/./docs"

COMMAND:> PASV
227 Entering Passive Mode (194, 168, 120, 124, 184)

COMMAND:> STOR newworship.htm

STATUS:> Connecting FTP data socket
194.168.54.120:31928...

ERROR:> Access denied

Please can you explain what I’m doing wrong? The Remote server file directory is shown as ‘/./docs’. Under this are listed 2 folders named ‘Church’ and ‘images’ plus 8 individual ‘*.htm’ files. I obviously have access to the server for these remote files to be listed and cannot understand why I cannot add this new file.

  ade.h 22:51 11 Sep 2006

Your directory address seems odd; when uploading to a sub-folder, it would not normally be preceded by the extra syntax. Are you sure that it is correct? Can I take it that you have used that path before with success?
If you are certain that the path is correct, try another FTP app to narrow down the possible causes.

  CLONNEN 07:23 12 Sep 2006

I use Virgin's webspace.

The FTP upload address is ftp:// upload.virgin.net - I usually just enter this in any Windows Explorer address bar - then I enter my Virgin Login Username and Password.

I used to use an FTP application but it didn't seem to work with the Virgin upload address a lot of the time - just use Windows Explorer to do it.

  CLONNEN 07:24 12 Sep 2006

Ignore the space in the FTP address.

  CLONNEN 07:27 12 Sep 2006

You should then see a list of your website files - just copy and paste your updated files into it. Same as you would with Windows Explorer.

  CLONNEN 07:32 12 Sep 2006

You should get a messagebox pop up asking if you want to overwrite the existing files. Click Yes To All button to allow the files to be updated.

I think this is the problem with the FTP programs - they don't seem to allow overwrites on Virgin's webspace. I used to have to delete the files from the webspace and then upload new ones in my FTP program - it was too time consuming so I switched to using the Windows Explorer method which allows me to just do one big Copy and Paste for all the files without having to delete things.

I hope this helps.

  Charlie Babbage 11:09 12 Sep 2006

Many thanks for your suggestions, particularly from Clonnen which looked very promising initially.

I had used IE v 6.0 to access ftp:// upload.virgin.net in the past but had forgotten about it! Maybe because of this it did not prompt me for user name and password but immediately listed the files in my Freespace. However, after copying the new file I want to upload, I now get the following error message:

"An error occurred copying the file to the FTP server. Make sure you have permission to put files on the server.

Details:
200 Type set to I
227 Entering Pasive Mode (194, 168, 54, 120, 46,
114)
553 newworship.htm: Permission denied"

Any other suggestions would be welcome. I know that Virgin Net recommend a different FTP app but cannot understand why this should make a difference. I know that I used up my free trial of the recommended app and don't really want to spend more to get the full version only to possibly find that also may not work!

  CLONNEN 18:34 12 Sep 2006

Does the ftp address you are trying to upload to show a slash on the end? I've just looked on Google and someone seems to suggest that if the last slash isn't present you cannot make changes to that directory. Here's the extract :

When I want to copy/move a single file to hidden_dir_2 (ie. the target specification in the copy/move dialog box is "/#ftp:click here"), I get "Permission denied". If I manually add a trailing slash (ie. target specification "/#ftp:click here"), it works fine. Copying/moving *multiple* files also works fine even without a trailing slash, somehow mc seems to automagically do the right thing in this case.

  CLONNEN 18:39 12 Sep 2006

Here is what the 553 error actually means :

553 Requested action not taken. File name not allowed.

What's the name of the file you are trying to upload (any non-letter/number characters for example)? Also what is the file extension? I think Virgin don't allow certain types of files on their free webspace.

  CLONNEN 18:55 12 Sep 2006

Sorry you said in your post - newworship.htm

Have you tried right-clicking on the newworship.htm file (the old one you are trying to replace) and selecting CHMOD (might be called Permissions or something similar). Are you set to full permissions access - read and write? Possibly the write access isn't enabled. I think it should say 644.

  CLONNEN 19:05 12 Sep 2006

Just thought of another possiblility - do you have a Firewall switched on?

Try disabling it and THEN try uploading your file. Apparently some firewalls automatically treat FTP traffic as read-only.

Turn your firewall back on after your FTP session though.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Ryzen news - release date, UK price, features and specifications

The pulp art of 80s computer game magazine covers

Best value Mac: Which is the best £1249 Mac to buy

Comment faire des captures d’écran sous Windows 10 ?