Cannot un-install Syfer Laptopalarm

  walmac 14:20 07 Feb 2009

IN PC Advisor, April 2009, page 95, under Set up laptop security system.
I downloaded and installed the Laptop Alarm from> onto my desktop.

I then tried to uninstall it using the provided
uninstall program but it left behind the Sysfer Directory containing the file laservice.exe.

I cannot delete this file even although it is not marked 'read only, system or hidden'. Also since this installation I now get a loud clicking noise every time I select a file, directory or program.

I did rootkit and bot searches with negative results.

I have been through Registry and deleted all references to Syfer and Laptop alarm.
I also re-installed the prog. and attempted to un-intall but again the same file was left.

It seems that this program has hooked some core part of the system that is not visible with the usual tools.

Can anyone assist?

ps I am awaiting a response from

  walmac 14:23 07 Feb 2009

I am using Windows XP Home Edition and have all up to date amendments.

  User-1229748 14:29 07 Feb 2009

could try revoclick here

  brundle 14:33 07 Feb 2009

I would expect that the file is actually running, so can't be deleted. Open Task Manager, find laservice.exe , right click and select End Process. Then delete the file and folder. Use the Tools page of CCleaner to delete its entry from the startup list. click here

  brundle 14:34 07 Feb 2009

End the LaptopAlarm.exe process too, if it's running.

  walmac 21:23 07 Feb 2009

Thank you 'smackheadz', nice little prog.
Thank you also 'brundle'.
1. The file is not shown running in Task Manager.
2. Laptopalarm process is not shown either. :(
3. When I re-installed the prog. I un-installed it in Ccleaner, but this too left the errant file!
4. I managed to delete the file and directory using 'Unlocker' which I forgot I had, this cleared the entries but the 'click' on selecting a file or program remains.

I feel that as this is a 'Security Program' it is not as easy to delete and it is still there perhaps at kernel level.

Thank you for your assistance.

  brundle 22:27 07 Feb 2009

Worked fine on a virtual machine, installation and removal.
The only reason I can see for it hanging around is that LAService.exe runs as a child-thread of spoolsv.exe, which is responsible for things to do with printers. Killing that process too may finally kill it. It's not embedded itself very deep at all. I didn't hear any `clicks`, no sound on the virtual machine.

  brundle 22:30 07 Feb 2009

It is worth mentioning, if the small red triangle is showing in your system tray when you choose to uninstall it (which indicates Laptopalarm.exe is present and running), the uninstaller won't stop the process for removal, in that case you will find it's still there when you reboot. Ensure the processes mentioned before are stopped, if you intend to re-install just to fix the problem , also ensure the processes have been stopped or the installer won't be able to set things up for you to remove them cleanly.

  walmac 14:13 08 Feb 2009

Tried this and it worked. Thank you for your assistance.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?