Cannot read zip discs

  carlos 14:58 20 Jan 2003
Locked
  carlos 14:58 20 Jan 2003

Hi, be v. grateful for any work-around: for some reason , one of my guys has been using their zip 100mb disc( PC format) on PCs and Macs, going between each several times. They now cannot read the discs on PC or Mac. Any way that the data can be easily retrieved??( data is not invaluable) Or is this a lost cause

  pj123 15:05 20 Jan 2003

I had the same problem with my zip drive and found that if you unplug the power supply lead and count to 10ish and then plug it back in again it worked. You might have to do it a couple of times. give it a try. Obviously I don't have a zip drive any more as CD rewriters are so much more economical - 650mb against 100mb and CDs are 30p to 40p against £9 for zip disks.

  carlos 15:48 20 Jan 2003

Tried with no success. Have taken zip disc to several other PCs( each with internal zip drive) and the disc won't open on any. I suppose its snaffued?
I agree with you re CDs, costs etc. We now have them as well. But zips are better for temporary storage/transportation of info, whoever........ replacing with memory sticks now.
Thanks again!

  Diemmess 17:08 20 Jan 2003

Before you despair have you tried IOMEGA's helpline? .......... It used to be an 0800 number in deepest Ireland. .....

I had a lot of trouble with a 1 Gig Jaz drive which they replaced three times and one Jaz disk as well. All at no charge to me.

I eventually discovered it was a SCSI termination problem and no fault of theirs at all.

  carlos 09:25 21 Jan 2003

will do.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?