cannot re-install win 98.Memory error in scandisk

  maxirv 20:38 04 Apr 2005

hi all. This is an ongoing problem which I have been making worse & worse with my efforts to repair! I won't blame you atall if you leave me to fester in the mess of my own making!

I tried to copy the links for my previous posts here but it doesn't want to let me do that for now, maybe later?

I have now tried all the advice given on here, and done all the things suggested on the Microsoft web-site for troubleshooting the error-messages i got. I still have no applications or anything except wallpaper in normal start-up. When I tried re-installing Windows 98, it recognises the cd,runs scandisk to check all system, about 2/3rds through directory structure check it says there is an invalid long filename which scandisk can't fix - run scandisk for windows to fix this problem. click ok to continue, it then carries on until near the end of "free spacce" check, when it says "problem found. The amount of free space on drive c is being reported incorrectly. Choose fix it to have scandisc correct the problem" but the when you say "fix it" it just says "Setup found errors on your hard disc. You must repair these errors before continuing with setup. For more information see SETUP.TXT on setup disk 1 or the Windows CD-Rom. Press any key to quit setup."

Help? Please?

  Dan the Doctus 20:49 04 Apr 2005

Are you trying to install over the top of Win98 or is it a clean install? For a clean install you should format the C: drive first (make sure you backup any files you want to keep beforehand).

  maxirv 21:04 04 Apr 2005

I had been trying to install over the top. I hadn't backed up for a while & have some music & stuff I'd rather not lose. But i have to say at this point i am perilously close to throwing it away - so perhaps a clean install might be a better option. Any other options? Or is it "baby with bath-water" time.

  Dan the Doctus 21:12 04 Apr 2005

You could always buy a new hard drive and install to that. Your existing drive could be set up as a slave device so you could perhaps keep most/all the data on it, or back the data up on it and reformat it etc.

  Dan the Doctus 21:18 04 Apr 2005

Another thought, if you have another partition you could use the DOS COPY command to copy your files to it.

  maxirv 21:19 04 Apr 2005

further startup problems
maxirv Mon, 21.03.05 | 18:54
i have now managed to access my system registry after a protracted previous problem which I won't go into (click here). I now have restored to the day it all went pear-shaped, but it still won't load anything. I get a message saying "Cannot find a device file that may be needed to run Windows or a windows application. The windows registry or system.ini file refers to this device file, but the device file no longer exists. If you deleted this file on purpose, try uninstalling the associated application using it's uninstall or set-up program. If you still want to use the application associated with this device file, try reinstalling that application to replace the missing file. C:/progra~1/mcafee/mcafee~1/cyberkrn.vxd.
My problem is (amongst many many others) I have no idea what application it is talking about. Microsoft advised me to remove any old mcafee or norton virusscan, since I have a new Norton Internet Security I assumed the Mcafee was the cause of the initial problems and removed it. As I don't remember how the Mcafee got here to begin with I can't reintall it (even if I had any desktop icons to begin with, which I still don't). I am on the verge of throwing the PC out of the window & making do with the laptop, except theres some REALLY good music on there which I'd hate to lose! Any advice would be much appreciated.

Fruit Bat /\0/\ Mon, 21.03.05 | 19:36
click here

maxirv Mon, 21.03.05 | 20:00
Thanks. I am scared to do this "regedit" stuff as this is what caused the problem to begin with. Also, I have no "Start" to "Run" from! It's there in Safe Mode, will this still work? Someone reassure me!

maxirv Mon, 21.03.05 | 21:11
oh dear...
i tried that. Still no luck. Everything is there in Safe Mode, but on ordinary boot up it is nowhere to be seen! Should I re-install Windows?

alan227 Mon, 21.03.05 | 22:38
You might have to do a repair install of windows which will leave your document & applications intact. The link below is an excellent guide to do this from Powerless.
click here

maxirv Mon, 21.03.05 | 22:51
thanks for that. I'll try it tomorrow - for now I am boggle-eyed looking at registry's trying to see whats wrong (not really knowing quite what I'm looking for!). Still - I havn't thrown it out the window yet! i'll let you know how i go - (well i'll probably be back begging for more help truth be told)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires