Cannot re-install Canon scanner

  Angry 23:05 27 Jan 2004

I have a CanoScan D1250U2. I am trying to re-install it after having my faulty hard drive replaced. When I plug it in to USB port the system does not recognise it as new hardware. I have tried using install new hardware wizard which just asks me if I have disk and then instructs me to insert disk and select the correct drive, after which I get the same box back. I have tried going to Device Manager but there is no scanner shown in Other Devices and Imaging Device is not there. Canon suggested deleting the USB and clicking refresh but I don't know how to do this. The scanner installed easily when I first did it and gain last month on a lap top. I have tried downoading driver but haven't a clue what to do then. Please help

  VoG II 23:21 27 Jan 2004

You need to unplug the scanner, run the software off the CD then plug in the scanner when prompted. Apologies if you've already done this.

  Djohn 23:28 27 Jan 2004

With a USB scanner, you will need to load the software before attaching the scanner to the PC.

First of all remove all traces of any software and hardware installation to your PC [This can be done from control panel, Add/remove programs] and disconnect the scanner from the PC.

If you have the driver on a CD or a floppy, install the software then connect the scanner when this has finished.

If your driver is one that you have downloaded to somewhere on your PC, it will be an exe. file. Find the file and double click on it to install the driver, then as above connect the scanner after the driver has installed.

Ignore the small window that may come up in the bottom right of your screen saying "New hardware". this will go away by itself.

If you need any more help, please post back and I or one of the other forum members will advise further. j.

  Djohn 23:28 27 Jan 2004

Sorry VoG, posted before refreshing. :o(

  VoG II 23:33 27 Jan 2004

No worries - you've posted "how to" - mine was merely a "tip". At least we're agreed on the root cause. :o)

  kacee 09:12 28 Jan 2004

Many thanks for the help - got a bit lost I'm afraid. Uninstalled and re-installed software and then plugged in USB & nothing happened. Still no sign of scanner in device manager. I think I have downloaded drivers (Scangear Toolbox & ScanGear CS-U) now but when I double click am asked whether I want to unzip, if I press yes I get a message to say unzipped successfully and then when I double click I get the same unzip dialogue box. If I chose to run winzip I am told it is not there. I am in a bit of a mess. Operating system is Windows XP Home.

  Jester2K 09:20 28 Jan 2004

When you unzip the ScanGear (this is the only bit you need) does the installation wizard not start?

After the Unzipped Successfully message you should then click OK and the drivers will install.

Also are the USB ports round the back or on the front of the case?

Who installed the new drive?

Do other USB devices work ok?

Any Yellow Exclamation Marks or other warnings under Device Manager?

What is listed under USB Controllers?

What motherboard?

USB 1 or USB 2?

  kacee 09:46 28 Jan 2004

When I unzip ScanGear the installation does not start. I get a message to say it has unzipped succesfully - I click OK and nothing happens & then the same dialogue box asking me to unzip.
The USB ports are round the back.
I had to install the new drive because a problem with Mesh. But the scanner installed OK. I had to then have floppy drive replaced and then reinstall Windows because of another problem, now I am having problems with scanner.
Other USB devices (external modem) work.
There is a yellow excalmation mark - Video Controller (VGA Compatable)
Under USB Controllers - USB 2.0 Root Hub
USB Root Hub (3 times) VIA Rev 5 or later Universal HOst Controller (3 times) VIA USB 2.0 Enhanced Host Controller.
Motherboard - Asus A7V8X
USB 2.0 I guess.
Hope all this helps - I haven't a clue what it is all about.

  Jester2K 10:08 28 Jan 2004

I'm just downloading your drivers from click here (6.2 mb)

I'll see what happens when i open it. I've got the Canon N1240U on WinXP and it uses the same sort of package....

  Jester2K 10:10 28 Jan 2004


Once you double click the file make a note of the location the drivers are being unzipped to. By default its C:\windows\temp Once the files have been unzipped you then need to go to c:\windows\temp and run the setup.exe.

probably best to delete all files from c:windows\temp first and then rerun it or make a folde called c:\scanner and then change the box to read c:\scanner before hitting the Unzip button. Then run the setup.exe in the c:\scanner folder.

  Jester2K 10:12 28 Jan 2004

1) there isn't a setup.exe file....

2) Even though i have WinZip installed the download insists i don't...

Have the motherboard drivers been installed?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?