Cannot install MP navigator for Canon MP610

  TMA88 22:31 09 Jul 2008

I have bought an all-in-one Canon Pixma MP610. Unfortunately I cannot, in any way, get MP navigator installed, which you need for the scanner. The printer however works fine. When I try to install MP navigator the installation just stops before the end(at 80%)of the installation with the following message: "An error occured while copying files".
I already tried the following actions without result:
- downloaded the latest drivers from the Canon site and tried to install them
- Disabled Antivirus en firewall program
- Started in safe mode and tried to install MP navigator here, but same message occured
- Switched back from Windows XP home SP3 to Windows XP home SP2
- Switched from IE7 to IE6
- Removed all twain files from folder windows/twain_32\ and tried to install MP 610 software again
- Tried to connect the scanner driver via hardwareconfiguration, but without success. Here is indicated that there is no driver installed and that the device is swiched off (code 22). Installation of a driver gives a mesage code 18 (device is switched on, but might not work properly) followed by code 22 again. MP610 series is however displayed.

When I currently switch on my AIO I continuesly get the message at the bottom right that new hardware is detected and this switches between "Canon MP610 ser" en "MP610 series".
I am getting really desperate at this moment. The Canon helpdesk states that their software works and that I have to contact Microsoft for this, but I am not getting any support there. So that brings me nothing. Please can somebody help me with this, because my All-In-One is now an Only-One and that is not where I bought it for. The AIO itsself works fine (copying, bluetooth connection, cardreader), so the device itsself seems to function well. I have a PC HP pavilion with Windows XP home SP2. I use an USB shielded high speed cable 2.0 revision on a 2.0 USB connection at the backside of the PC.
All help is welcome!!

  JMH1946 08:06 12 Oct 2008

I have recently purchased a Canon MP 610 and I am experiencing the exactly the same problems as detailed in your post,

I note your post was placed on the 9/7/08, have you been able to resolve the problem?

If so can you supply some details.

  TMA88 10:50 12 Oct 2008

I could finally only resolve the problem by returning the computer into its original state (via original installed recovery partition). It is a lot of work, because you have to reinstall all updates and programs again, but it paid out. My AIO is now working completely correct. Also it is a good opportunity to wipe you computer clean. Conclusion is that it has something to do with the (Windows) configuration of the computer.
Hope this can help you too.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?