Cannot identify HDD enclosure

  Catastrophe 11:51 08 Nov 2006

This is not a hoax.

I have found an enclosure which I cannot open. I know that sounds strange but there appear to be no screws or other means of fastening and very little identification.

Along the front there are 2 firewire and 1 USB sockets followed by power supply and on/off switch.
Below these are:
CE F(c) 5621 (written in red over something like a yin yang symbol then pin diagram under power socket then power symbol.

There are rubber like legs underneath and I wondered whether fittings might be under them but they don't pull easily and I don't want to be too tough on them unless someone can tell me there are such enclosures.

Failing that has anyone got a seemingly unopenable enclosure? I have tried pushing, pulling, sliding etc to no avail. I have tried many Google combinations.

Thanks in advance for any suggestions.

  anskyber 12:00 08 Nov 2006

It could be as you have suggested a crimped fixing under the feet.

  Totally-braindead 12:05 08 Nov 2006

All I can say is that mine has no screws or anything on it. To open it you actually push in part of the case and then it swivels open.
There are screws but these are internal and only to stop the hard drive from moving in the case, the actual 2 parts of the case clip together.
It is possible that the case is glued together, though I haven't seen one.

  Spark6 12:23 08 Nov 2006

If it's any consolation I have a Western Digital external drive, Mod. No. WD800b014-RNU, that has no apparent means of disassembly. I was unaware of this until I read your post and decided to check!

When it is laid flat it is supported on four 20mm by 5mm rubber pads, vertically it is supported on two detachable feet.

To date I have not had reason to interfere with it, but you never know. You are referring to an external HD enclosure I believe.

Wishing you the best of luck with this post, I take it that the drive is kaput, and looking forward to learning of the outcome.

  Catastrophe 12:28 08 Nov 2006


I have removed one of the feet and that is not the answer unless there is a screw under one or two only which I find unlikely, especially as it was so difficult to remove.


Does yours have a number 5621? Although I think (from Googling) this may be a standard. Can you detail a little on where you push? Strange there is so little identification.

Many thanks for your replies.

  Catastrophe 12:32 08 Nov 2006


Yes it seems kaput so I wanted to see if I can use another as I have several spare HDDs. If I find a solution I will post. If I do not post you can assume I didn't find a solution.

Can anyone throw any light on 5621 over a yin yang sign?

  Spark6 16:17 08 Nov 2006

Are you able to provide a screen shot of this mystery?

  Catastrophe 17:32 08 Nov 2006


click here

Rotate 90 deg clockwise.

Write 5621 in red. Yin yang red. The rest white.

Are we now saying that there are external drives which are 'hard wired' - not having usual IDE and power connections?

The other external I have has 2 screws which allow access to interior when HDDs can be changed.

  Pineman100 17:52 08 Nov 2006

I've got an oxy-acetylene torch you can borrow.

  Spark6 20:48 08 Nov 2006

The 'mystery' I referred to was the enclosure not the symbol.

  woodchip 20:58 08 Nov 2006

Mine as Half Buttons at the side. Do you have a Digi Cam you could post a Picture link through click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?