Cannot format/erase dvd-rw in vistaaaaaargh

  theDarkness 23:50 07 Jun 2008

I have also tried ashampoo to format a dvdrw but i either get a 'windows unable to complete the format' message, or the disc will seemingly format but not burn content correctly. It could well be the drives fault with my msi laptop and not vista itself, as the drive is painfully slow at updating disc content sometimes.. eg i insert 3 discs and the name of the first is still showing when i click on my computer.. or i insert a commercial dvd and it asks me if i want to burn content onto this 'blank disc'! lol

  theDarkness 03:04 06 Jul 2008

Could the slow access and telling me a disc is blank to reformat when its not, be a simple driver problem if its not vista causing the problem? I have no internet access on my mesh msi laptop to try updating though. Has anyone had slow cd or dvd drive access on their mesh laptop, or copy of vista? My dvd drive is a optiarc ad7530B model. I just dont want to chance updating the drivers to find out it might make things worse or not be vista compatible.

  eedcam 12:23 06 Jul 2008

You should'nt need to have to format a disc.You could try Imgburn and see what what that comes up with click here
Once istalled put your disc in and choose discovery it will give you all the infoonthe disc if your reader is ok. I know you dont want to update but Imgburn can check for you if there are any available Tools>drive >check for firmware updates

  pj123 12:39 06 Jul 2008

As eedcam says, you don't need to format any RW disc, whether it's a CD or a DVD.

I don't use RW discs very often because they are not very stable, but I have never formatted any of them.

I use Nero in multisession mode.

  theDarkness 14:35 06 Jul 2008

if it tells me theres an empty disc (when its untrue!) and whether i want to write to it, to get the drive to read correctly i have found if i put in a non rewritable disc (eg game cd or dvd) it will then read the contents ok after that. Still no use, like you say, if i was trying to read content from a rewritable, as the drive would erase all content anyway instead of read it! If that drive checking program is not too big, i will try it out and download it using this phone, thanks. I connected this phone to try and find updated driver and it said theres none available, but i will report what happens with the program from your link, thanks everyone. Ps i have found with rws on my desktop pc i need to write at a very low speed with most to avoid errors, havent had any prob with any brands, but have hardly ever used them

  theDarkness 14:43 06 Jul 2008

Ive just put in a disc again and its giving me an empty disc, when its a bought computer game. The last disc i had in before this was a blank though, lol. It reads contents eventually when i click on "ok" when it tells me it needs to reformat it, so it must try and burn to it and then finds out its impossible to do so. I just hope im not damaging any discs when i use this method, hopefully its just a forced check and nothing more

  eedcam 16:25 06 Jul 2008

Imgburn is'nt just a drive checking programme its a full blown burner

  theDarkness 02:06 12 Jul 2008

I found the problem i have with vista not always listing content of a dvd disc, always asking if i want to burn to it- even if its impossible to do so, is very common! No idea how i can solve it fully though click here

  rdave13 02:14 12 Jul 2008

Find another burner, a search engine might help.

  theDarkness 22:49 13 Jul 2008

Im fairly certain its not a problem with the drive in reading discs in itself since i found others with the same issue using different brands, and not a problem with any dvd burning programs either, as i have tried more than one, and still get a 'prepare this disc for burning' message with any disc i want to explore that is not a blank. Thanks for the replies, i will still need to update vista to see if that sorts it once i get net access. if anyone is having similar problems with vista inserting and exploring dvd or cd discs i would still like to hear about them

  MCE2K5 23:58 13 Jul 2008

Sounds like Software Conflict or a Duff Drive.

I have Nero 8, Ashampoo B/S 7 & 8 and Easy Media Creator 10 Suite.

All running on Vista Ultimate with no Problems at all.

Have just Erased 4 DVD-RW's with the above Progs and Formatted One DVD-RW with Vista, All went smoothly, although Formatting took a while to do.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?