"Cannot find the specified file" copy to MP3

  StuFromPoole 10:19 24 Nov 2007
Locked

HI, I am having problems transfering MP3 podcasts from my PC to my MP3 player. The file copy / move runs about half way through then stops with the error message "Cannot copy (filename). Cannot find the specified file. Make sure you specify the correct path and file name.

Why is this happening? I am not ding anything different from normal - This has only occured in the last week or two. I have tried two MP3 players with the same result.

Any help greatly appreciated.

  johnnyrocker 11:00 24 Nov 2007

is it only one file which may be in a different format?


johnny

  StuFromPoole 11:46 24 Nov 2007

Johnny,

These are just downloaded Podcasts, all in MP3 format, some transfer fine others will not.

The files are all downloaded by subscription using Juice so I don't do anything except transfer them to my MP3 player and listen.

Up until now, this has always worked fine and of the four podcasts I downloaded this week, three are OK and one will not transfer?

For example, last weeks podcast was 15.6 meg and transferred OK this weeks podcast from the same provider is 19.6 meg and won't transfer.

I tried changing file names too but this had no effect.

  I2usty 04:35 15 Jun 2008

Hey all, just found your thread as i've been having the same problems for the last 3 days or so (this problem was only "discovered" 3 days ago) and have still had no luck in finding a solution.

Along with the "Cannot find the specified file" error i have been getting a "cannot copy file, the path is too deep" error as well.(i also tried changing the file name, Stu)

I had originally been trying to copy a file from desktop to a USB key with ample room for the files which resulted in the above errors, i then tried to copy a file from my local home network with the same results.

I have tried every solution in every thread i have read on this issue with no luck at all but the one recurring problem everyone seems to be having is the fact that USB is involved in one way or another.

Of course i'm only assuming here but for lack of a better answer i'm going to blame SP3 as the problem.

It looks to be some kind of 'time-out' as the file will attempt to copy, along with giving a 'time until finished' estimate, only to error after a few minutes.

My flat-mate runs Linux and copied one of the very same files i was having trouble with across the network without any problems at all.

In closing, my system has had only one noticeable change since i've started having troubles with this and that has been the aforementioned SP3 update. I have heard people having some success with the old USB 1.0 ports but as i don't have any of these i can't try them.

Hopefully there will be a discreet little windows update soon and this whole mess will go away.
Anyone out there with any positive results for this issue, please don't hesitate to post your success.

Cheers.

  Charon9 07:34 18 Jun 2008

First up: Service Pack 3 (WindowsXP) - was released May 6, 2008. I think if there was a problem it would have shown up before now, and there would be a bit more buzz about it being that since so many use the OS.

Second: All Memory is the same? - not even close, and memory controllers are another problem to add on that list. There are a LOT of "Non-Standard" memory types out there; and without knowing the exact memory device you are using it would be hard to diagnose that type of problem....

Third: USB Port devices are likewise not the same, added to the fact that USB polling (with lots of high I/O can cause even more problems).

Your answer however is more than likely much simpler. FAT12 and or FAT16. Both of these older file formats (Commonly used on USB drives, devices - Every single one I have purchased is FAT16 out of the box and most 'software' reformats them in FAT (or FAT16)) will NOT take long file names or directories that exceed its FAT size - Translated, you can only put in so many files, or directories within directories before the "File Allocation Table" (FAT) is full.
FAT12/16 Limits names to 8.3 (8 characters .(+) 3 characters) - some FAT16's allowed LFN (255).
FAT12/16 limits directories (or nestled directories) to "260 bytes"
or:
512 FAT entries (LFN's = 2 entries).
File # 513 = error (short file names).

see:
click here
(Post #2) or;
click here
click here

How to Fix. See if your device(s) will format in FAT32 or reformat in FAT32 that supports LFN's, and nestled directories (plus LARGE) file sizes.
BUT.. Make sure your devices (MP3 players) will work in FAT32 mode (some won't).

  Simsy 08:52 18 Jun 2008

when trying to read from a usb flash drive...

It turned out that the USB drivers were being tempremental. uninstalling and reinstalling the usb drivers sorted it.

Assuming that you are using a USB connection this might be something similar as, I presume, the PC will need to keep checking the mp3 player to make sure that the copying has happened.

Good luck,

Regards,

Simsy

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone