Cannot Defrag

  Jolson 12:44 19 Jul 2003

XP Pro system
Will not defrag beacause of inconsistencies on disk.
Tried error-checking on C:
Check could not be performed because utility needs exclusive access to some files.
Files can be accessed only by restarting Windows.
When restarted, message received just before desktop opens:-
"Checking Files system in C.
The type is NTFS.
Cant open volume for direct access.
Windows has finished check."

No error-cherck, no defrag!

Any suggestions please.


  hugh-265156 12:51 19 Jul 2003

try running from safe mode.

  Jolson 15:09 19 Jul 2003

Many thanks huggy71

Have tried running from Safe Mode and Safe Mode with Command Prompt but in both cases the listing stops at "multi(0)disk(0)rdisk(0)partition(1)\windows\system 32\ drivers\ amdagp.sys" with no flashing cursor.

I am beginning to think there may be some work ahead of me to get things right!


  hugh-265156 15:39 19 Jul 2003

do you have an AMD board?if so update the drivers.

click here=|+language%3Aen&ct=1325960345&qm=1&ql=&lk=1&rf=0&ws=1&tqmhak=0&lap=en

might help.

  hugh-265156 15:41 19 Jul 2003

oops this one even
click here=|+language%3Aen&ct=699239417&qm=1&ql=&lk=1&rf=0&ws=1&tqmhak=0&lap=en

  hugh-265156 15:43 19 Jul 2003

sorry try selecting uk from the choose location box and search for miniport_533.exe to get the uk one.

the link doesnt work sorry.

  VoG II 15:46 19 Jul 2003
  hugh-265156 15:50 19 Jul 2003

thanks VoG,i keep forgetting about that.

  Jolson 16:37 19 Jul 2003

I have installed Miniport-533.exe but unfortunately the listing still stops at the same point in the listing.

Many thanks to both huggy71 and VoG for the info.


  hugh-265156 16:50 19 Jul 2003

i really have no idea now.most google links are about hangs at start up re/amdagp.sys

try putting the windows disc in the drive

click start then click run and type

sfc /scannow (note the space between sfc and /)

this will check and fix any damaged system files.

  BillEmm 17:03 19 Jul 2003

on the last time you defragged.

If you have a lot of activity on your disk and don't defrag frequently then the disk becomes so fragmented that no defrag program will work - mainly due to the amount of storage it requires (both RAM and HDD).

If this might be your problem the only solution is to remove as much data and programs from the drive as possible. Delete the recycle bin and all temp files. Move data to another drive or quality CDs and uninstall infrequently used programs (they can be re-installed when necessary).

Then try the 'safe mode' approach again.

If I have got it wrong then this may serve as a word of warning for other unsuspecting viewers.
Defrag your C: drive at least once a month.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires