Cannot connet with netgear wireless card

  Chris251 21:20 22 Oct 2007

I have the BT home hub but I can only access the internet use the ethernet connection. My laptop is a few years old so I had to buy a wireless card. I have installed Netgear WG511T and it seems to be installed ok but when I try to connect using wireless the signal is strong but it states 'This connection has limited or no connectivity'.
Can someone please advise what I need to do to set up wireless properly.
Thank you

  daxian 22:36 22 Oct 2007

hi chris251...
the limited connectivity is usually a sign that the router is not giving an ip address to you pc (card).
get the latest drivers for the card and see if that improves things . Dave.

  ambra4 04:47 23 Oct 2007

Go this site and go down to “Connection via wireless section”

click here

  Chris251 18:59 23 Oct 2007

Thank you both daxian & ambra4 for your replies.
I thought I was quite computer literate until I tried to go wireless.
Im not sure about the driver so I tried the website you gave me ambra4. I followed all the instructions, logged onto BT homehub and everything seemed to be ok. When I tried to connect it said 'limited connectivity'again I clicked repair and it said this was because it could not renew my IP address. Can either of you tell me how to do this?
Sorry if I am doing something completely wrong and I really appreciate your help with this.

  ambra4 19:30 23 Oct 2007

check this wireless sections

#Can't connect via hub#

click here

  bowman 20:48 23 Oct 2007

I had a similar problem, "limited connectivity"

My Laptop built-in wi-fi adapter would not connect to my Netgear WG843gt router.

I changed the security settings in the router and the laptop from WEP to WPA-PSK, and it worked. Worth a try?

Hope this helps.


  bowman 20:53 23 Oct 2007

oops! that should read Netgear DG834GT router.

  daxian 21:10 23 Oct 2007

hi chris251.....
the router is not the problem ....the wireless card is ....update the drivers .
easy to do... goto the netgear site dowload the latest driver ,uninstall the software you have in now ,then run the new driver software.
even though you just got the card, newer drivers will be available and will solve the problem you are having.Dave

  Chris251 18:58 25 Oct 2007

Hello Dave,

It worked!!! thank you very much. I finally put all the wires in the box where they belong.
Thank you to Phil & ambra4 for replying too.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017