Cannot connect to secured wireless network

  6511 15:34 25 Dec 2008
Locked

I purchased a Linksys WRT610N dual band wireless router and Acer Anspire 6930G laptop last Saturday.
Linksys manually configured my router to work on my Windows XP desktop and alos enables a sucure connection on the band 5 + Band 2.4 networks.
However, when I open up the 'networks available' tab on the laptop running Vista, I can see both networks, but when I right click to get the passkey box up to log in, I get a different box, which tells me I need additional information to log on.
When I click on the message, I find three boxes, login; password; and domain name to fill in. I have tried all combinations I can, but none will allow me to connect.
When I right click on another network displayed the expected keypass box appears.
Can anyone advise what might have gone wrong? The router accepts a/d/g/+ draft N WLAN and the laptop has a draft - n card.
I have now gone back into the router settings and disabled security, which allows my two laptops to connect.
I have removed the security settings and tried other combinations, but it still gives me the 'additional info box'.
Linksys set both bands up with WEP, but it also supports WPA-personal; WPA2-personal; WPA-enterprise and WPA2-enterprise. It is also set at 40/64-bit encryption, but also supports 104/128-bit.
Any help appraciated as I am stumpted and Linksys helpline tell me it is a problem with my laptop, not their router.
Robert

  ambra4 23:59 25 Dec 2008

Vista contains both the familiar IPv4 stack and the new IPv6 stack.

You do not need IPv6 at the present time disable IPv6 in all computers both on the Lan card and

wireless card, as it can cause connectivity problem on your network

Download the pdf file will tell you how to disable IPv6 in Vista

click here

  6511 12:53 26 Dec 2008

Hi ambra4
Have done exactly what you suggested both on the Lan card and wlan card by downloading file and following instructions.
Re-booted laptop but I still get the additional info required box, not the passkey box to log in.
Any other suggestions?
Robert

  6511 21:15 27 Dec 2008

worked it out myself pm yesterday.

  ambra4 22:26 27 Dec 2008

what was the problem

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?