Cannot connect to certain internet sites

  Blicker 19:24 23 Sep 2007
Locked

I have a new Dell Vostro 1000 laptop, virgin broadband and a Belkin G Plus MIMO router which the laptop is connected to wirelessly. Also have Mcafee SecurityCenter version 7.2 (hate it but it came free with the dell).

Connects fine automatically at start up and can get onto some sites with IE7 no problem, but a lot of important internet sites such as Microsoft, Mcafee, Mozzila (acidental alliteration there!) just dont show up at all, I enter the address but they never load. Windows cant even check for updates.

I'm 90% sure the router is at fault because my last laptop had the exact same problem and so did my dad's desktop. My dad fixed the problem for those 2 computers but that was years ago and he cant remember what he did!! I think I remember downloading some sort of update for the router to solve the problem but cant seem to find anything like that on Belkin's website. Could be barking up the wrong tree here I dont know!

Any help would be appreiciated!

  mgmcc 21:16 23 Sep 2007

This is the third posting I've seen in a forum about certain sites being inaccessible when using a Belkin MIMO router. The access problems include Microsoft's website, Windows Update and MSN. The conclusion has to be that there is a problem with these routers.

click here

click here

  STREETWORK 21:18 23 Sep 2007

I presume you are using Vista operating system.

1. win-key+R to open the run box
2. Type devmgmt.msc and hit ENTER
3. You may have to confirm the UAC
4. Expand Network Adapters
5. Right Click your NIC device
6. Click Properties
7. Click on the Advanced tab
8. Select IPv4 Checksum Offload
9. Set the value to Disabled
10. Click OK
11. You may need to reboot

Post back...

  Dipso 22:09 23 Sep 2007

I hope Belkin are already working on a firmware update for this router taking into account the number of people having problems with it.

  Blicker 09:23 24 Sep 2007

Thanks for the replies.

Tried to find 'IPv4 Checksum Offload' on the advanced tab for my NIC (Dell wireless 1390 WLAN mini-card) but couldnt find it!? Lots of other things that I can disable and enable, but none look remotely like it.

May email Belkin and see what they have to say...

  Blicker 17:28 24 Sep 2007

Heres what Belkin said:

"For isolating the issue please change MTU on the router following the below given steps.

You can change the MTU size on the router only, if you have configured the router
for PPPOE connection. If the connection type provided by your ISP is DSL and the
router is configured for PPPOE. Please refer the steps given below for changing the
MTU size on the router:-

- Open Internet explorer type in 192.168.2.1 and click on the Go.
- Leave the password blank and click Submit.
- Click on Connection Type
- Select PPPOE and click on Next
- Enter the MTU settings recommended by your ISP
- Click on Apply Changes.

If the connection type provided by your ISP is cable and if the router is
configured for Dynamic connection, you cannot change the MTU size on the router.
However, you can change the MTU size on the computer. The third party Dr. TCP
software can be used to change the MTU setting. This can be downloaded from
click here

- Unzip the Utility to your desktop.
- Run the utility.
- In the Adapter Settings pull down, select the Ethernet driver and adapter used to connect with the network.
- In the MTU box, type the MTU size as 1400.
- Click in any other box, without changing the data there.
- Click Apply.
- Click Exit."

And after trying to change the MTU on the router still no joy!

  Dipso 20:44 24 Sep 2007

Most UK ISP's, an exception is AOL, use PPPoA not PPPoE, are you with AOL?

Otherwise have you tried using the alternative method i.e. amending the MTU value on your laptop using DrTCP?

  Blicker 15:37 26 Sep 2007

I have Vigin broadband, which I hope is PPPoE because I've been setting everything up on all four of my computers I've had over the years with PPPoE as my connection type!

Tried DrTCP but didn't do anything, but I was in a hurry so I dont know if I was using it right. Might have another go!

  Dipso 16:56 26 Sep 2007

If it's Virgin ADSL the settings should be -

PPPoA
VCI=0
VPI=38
MTU=1450
Multiplexing Method=VC Based

  mgmcc 08:46 27 Sep 2007

<<<< I have Vigin broadband, which I hope is PPPoE because I've been setting everything up on all four of my computers I've had over the years with PPPoE as my connection type! >>>>

I don't know why you should have been using PPPoE because ADSL in the UK uses PPPoA and "Cable" doesn't use Point-to-Point Protocol to establish connections.

If you are using "Cable", it is probably ignoring attempts to negotiate a PPPoE connection and simply allocating the addresses by DHCP in the normal way.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?