Cannot access data on external disk

  gsirinian 10:42 24 Nov 2006
Locked

I have installed a Maxtor 120 Gb disk from an older computer in a USB external enclosure. I am running XP pro. Upon booting the external drive, which by the way contains data which I want to be able to access or at least recover, is not assigned a drive letter. Going into Disk management I see the drive but when I try to assign a letter (by right clicking on the external drive, which does show up there as an active disk with a single primary partition) the option to assign a letter is grayed out. I am looking for some suggestions on recovering the data on the drive before I write the disk off as bad. I am sorry if I have not been very clear but please ask me to add whatever additional info I must give anyone who would be kind enough to try to help me. Thanks

  johnnyrocker 10:45 24 Nov 2006

have you check it is seated correctly and does it show in 'my computer'? try a reboot with the external off then a reboot with external on and does the pc recognise it then?


johnny.

  main identity 11:13 24 Nov 2006

is it set up as a master and not as a slave

  Technotiger 11:24 24 Nov 2006

Hi, try a different usb port - does it not show up in My Computer?

  gsirinian 08:29 26 Nov 2006

Johnnyrocker: I checked and it is sitting correctly. It doesn't show up in "My computer". I tried rebooting with and without and it does not change anything. No drive letter assigned in either case

Johnny: It is set up as "cable select (no jumpers)

Technotiger: I tried other USB ports but no change. Besides on the same port and using the same port, other external disk devices which I own seem to work fine

Thanks to all of you for trying to help me. I appreciate it

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?