BTCPatcher.exe

  flobby 14:56 05 Jan 2008
Locked

Hi,
Can anybody help with this process?
I have looked into processes using task manager and have found 2 sets of BTCPatcher.exe running permanently, using between 2% and 30% usage each.
This causes slow running of programmes.
CAN I Just en

END the processes or at least one of them, and if so will it or both return when rebooted.
I have done scans using Bullguard antivirus and malware, and CCleaner and Easy Cleaner, which all state my Computer is clear of all bad things.
I am running windows Vista Premium
Thank you

  flobby 14:58 05 Jan 2008

PS. I did look up BTCPatcher in google but it was all in Spanish.
Cheers.

  Neilychap 09:10 08 Jan 2008

Hi,
Not sure exactly what this app does but it appears you can only remove it with a particular piece of software - no doubt you would have to pay for it too so maybe someone trying to make some money from nothing...?

Anyway, I came across this problem with a customers PC only last week so here's what you need to do:

You will need to search for BTCPATCHER.EXE in the registry (type REGEDIT into the RUN... option from the start menu). This will only find one instance of BTCPATCHER - delete this item. Before you do this you must stop the 2 BTPATCHER services running - they can be stopped you just have to keep trying. It is the registry key which starts the app running when Windows loads. While the BTCPATCHER services are running deleting the item from the registry has no effect as it puts it right back! A pain in the arse basically!

Neil.

  cocteau48 09:35 08 Jan 2008

Good morning Flobby
I thought you had resolved this as per your previous thread
click here

If so please tick as resolved.

  flobby 09:46 08 Jan 2008

Hi All
I apologise for not having marked this one resolved!! I forgot I wrote this post first, and upon getting no replies used the CPU Usage post.
The Resolution I used.

I set a restore point and then went into Safe Mode and searched for BTCPatcher and then deleted it.
I tried to delete it in normal mode but it stated that I did not have permission.
Up to now everything is working as it should (fingers crossed)
Thank you all for looking and replying
Cheers, Flobby62

  LegMan 17:52 20 Jan 2008

I have the same problem with xp pro. all though i could only find one patcher file under windows systems 32. Down loaded prvex and found it and terminated it. After that i ran good old fashioned (FREE) Sbybot search and destroy, and cleaned up 5 other issues. And rebooted with system restore OPF. then rescanned after start up. So far so good. I even found the BTCPatcher gone out of system32.This all started from a file i recieved from a file sharing program last week. i have Norton 360 and it all began as a Vundo virus and then carried on. Let me know how you do ?

  flobby 19:56 20 Jan 2008

As stated I just searched for the BTCatcher file in SAFE MODE and then Deleted it.
Rebooted and rescanned using everything , ie. Spybot search and destroy, Adaware, Adwatch, CCleaner, Superantispyware and my Bullguard Anti virus. And they could not find it.
And everthing is running fine up to now.
Cheers,
Flobby

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?