BT Home Hub Not Allocating IP Address to Ethernet

  Zeppelyn 21:21 21 Apr 2008

I have for the last few days been trying to get my PC to connect to a new V1.5 Hub via ethernet local area connection. All has worked ok until Saturday but the issue seems to affect my pc only as son's is connected to port 2 via ethernet OK and laptop connects via wireless ok. The connection currently shows as "Limited or No Connectivity" and properties of adaptor show IP in the 169.254 range with a Subnet Mask of and no Default Gateway.

The Hub does not report the connection under devices but the connectivity check passes OK using wireless.

As of now have had no luck solving and have tried the following:-

Windows cannot repair

Run BT Desktop Help - Could not fix, reported no default gateway

Uninstalled adaptor and rebooted, installed latest NVidia drivers, no change.

Changed ethernet cable and rebooted, no change

Tried manually inserting IP address etc, no luck.

Soft reset of hub did not work so then tried hard reset after leaving off overnight and disconnected from phone master socket, still nothing.

This was all using Vista so then removed main hard disk and inserted spare and installed XP, as soon as the Ethernet drivers installed XP also returned the limited or no connectivity message.

This led me to think the ethernet port was not being seen by Hub or kaput but the motherboard has two ports and when connected both show green light for OK.

Apart from getting PCI network adapter to try I am at a loss, has anyone here any experience of this fault?

  gudgulf 21:30 21 Apr 2008

Try one of the other sockets on the router.

My own router wont connect via the number 1 socket on the back of the router (Netgear) nor will my father-in-law's (Speedtouch)...both work fine through socket 2.NBoth get the limited connectivity warning when using socket 1

Try that one first since you know your sonc pc can connect through it,just to be sure it's not a problem with your pc.

  Zeppelyn 22:02 21 Apr 2008

Ok tried that but same problem although when son's cable is connected to Port 1 his PC connects ok.

  brundle 22:42 21 Apr 2008

Is DHCP enabled on the problem PC? And on the Homehub?

  Zeppelyn 22:58 21 Apr 2008

Definitely on the hub ye. How is it done on XP?

  brundle 23:02 21 Apr 2008

Start menu/run, type


press return.

Scroll down to DHCP Client. Click Start if it's stopped, change startup type to Auto if it's not already.

  Zeppelyn 23:16 21 Apr 2008

Its started and already set to auto.

  brundle 23:21 21 Apr 2008

Start menu/run, type


press return

ipconfig /release

press return
then type

ipconfig /renew

Does your PC pick up a 192.168 address after these steps?

  Zeppelyn 23:34 21 Apr 2008

No both report a 169.254 address still.

  brundle 23:35 21 Apr 2008

What's under the DHCP server heading when you type

ipconfig /all

at the command prompt?

Do you have a firewall running?

  Zeppelyn 23:53 21 Apr 2008

Primary DNS Suffix :
Node Type : Unknown
IP Routing Enabled : No
Wins Proxy Enabled : No
DNS Suffix Search : Home

Then goes on to say that DHCP and Auto Config enabled and gives the 169.254 IP and Subnet.

When I installed XP earlier there was no firewall except Windows, since installed Nortin. Yhe hub has standard firewall enabled.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?