BT Home Hub 2 - Wireless Conectivity Problem

  spruce 17:16 30 Aug 2009

Hi everyone,

Strange problem with BT home hub 2 (black), or is it Bt, but that is another story.

I received my BT Home Hub 2 approximately 1 month ago and I could connect to my laptop and to my spare computer. Both wirelessly, using the default WPA2 key. Which I am still using.

Last week I was unable to connect to either, I had changed no settings or altered anything.

I note that the Home Hub also broadcasts BTOpenzone and BTFON, which any man and his dog can log into.

I cannot log into my BTHomeHub2 login, which is set to automatic connection, or by manually trying to connect. This is at the top of the list of available connections.

I can log into the BTOpenzone and BTFON, but this has to be paid for, even though it is getting broadcast off my BT Hub. Great job BT, make money off other peoples connections.

I have searched the threads in this forum, but I have not found a solution.

Dugit resolved his problem by

"After suggestion I found about problem:
Went to hub manager/advanced settings and then wireless interface type chose 802.11b/g (it was 802.11b/g/n as recomended by bt).Problem has now gone."

This did not work for me.

Any suggestions will be greatly appreciated.

Also is there a way to turn off BTFON and BTOpenworld on the router.

I have phoned BT and they were not much help, I had tried all of their suggestions earlier.

Cheers in advance.

  spruce 17:34 30 Aug 2009

If I remove the security and use it as an unsecured network, I can connect!!!!

  Technotiger 17:38 30 Aug 2009

I have BT HomeHub 2 as well - but I have always understood that one has to sign up for BTFon, but only if you want to - I opted not to and have not had any problems at all.

  rawprawn 17:40 30 Aug 2009

Have you tried BB help 0800 800 030. they are usually very good, and (with your permission) take over your computer to rectify any problems.
It usually requires them to re register from scratch.

  Technotiger 17:40 30 Aug 2009

BTW my main Desktop PC is connected via cable to the HomeHub, and I have another desktop and a laptop both connected wirelessly via the hub.

  spruce 17:51 30 Aug 2009

Thanks for the responses so far guys.

The issue is not that I cannot connect, it is when the security settings are implemented that I cannot connect. I have tried changing to WEP in lieu of WPA/WPA2. Works fine when there is no security settings.

When you connect to BTOpenworld for example, it is shown as being an insecure network, that you have to put your email address in and password, so there must be some form of token exchange in order to implement the security on the fly.

Oh well I will keep persevering.

Any more thoughts or ideas will be gratefully accepted :-)

  Technotiger 17:59 30 Aug 2009

Have a good read through this click here

My own hub is set to WPA-PSK.

  spruce 19:14 30 Aug 2009

Thanks Technotiger, I have read that, alas it is not an option on the hub. BT must have disabled a lot of the access rights to the hub. The hub does not have the flexibility or options of a router, I wonder why!!

  Technotiger 20:43 30 Aug 2009

You could try System Restore back to when it was working to your satisfaction.

  T0SH 21:55 30 Aug 2009
  spruce 16:38 31 Aug 2009

Thanks for all of your responses guys :-)

I was not aware that I opted for the BTFON network, but now I know it was an option I will ask for it to be blocked.

Cheers, great job.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?