Browsing speed slower after installing new router

  robgrayson 08:01 27 Jun 2008


A couple of days ago I changed my modem/router from a Netgear to a Linksys (model WAG200G) in order to improve wireless signal strength. The install was fine and the router appears to be working fine, both via Ethernet and wireless.

Today I'm working on my main desktop PC, hardwired to the router by Ethernet. It seems to me that web pages are loading more slowly. When I click on a link to go to a page (especially one containing lots of images/icons etc.), firts of all there can be a pause for maybe a second or so while it is looking up the page. But the most noticeable thing is when I get to the page. It's as though I can see all the page elements being gradually loaded one by one. Overall it probably doesn't take that long to load the page, but it's as though I can see it being "built" an item at a time, whereas previously it was pretty much instantaneous. Could this have something to do with the change of router? (As far as I'm aware nothing else has changed.)

Another thing I've noticed - while a page is loading, the text shown in the status bar at bottom left seems to alternate repeatedly and quickly between "Waiting for [site address]" and "Connected to [site address]". I don't recall noticing it do this so much before. (But then again, maybe I'm starting to see things that aren't there...)

I'm using Firefox 3 on a 2.4GHz Celeron machine with 2GB RAM and XP Home. My internet connection is 8Mb downstream, and online speed tests suggest it is working at close to the advertised speed.

Thanks in advance,


  Kemistri 17:17 27 Jun 2008

It sounds like it might be dropping a lot of packets. Did you use the same advanced settings, such as the MTU value, as before?

  robgrayson 17:22 27 Jun 2008

Hi Kemistri,

I'm afraid I'm not enough of a network techie to have a clue what MTU size is, so no, I didn't carry those settings across. I've just checked in my new router's configuration, and there are two settings to do with MTU: Setting (auto or manual - set to auto) and size (set to 1500).

ANy suggestions?

  Kemistri 17:35 27 Jun 2008

Yeah, two things.

Either find out what MTU your ISP specifies, if any. They all have an optimum setting, but you can fiddle around it. With the Linksys in auto, see if 1500 is actually the right value or if it's misreporting for some reason.

Or, if you still have the old router, cable it up and switch it on (no need to do anything else unless you want to do a back-to-back to rule things out -- might be an idea, actually) and log in to its configuration menu to check what the previous settings were. Double check them all while you're there.

I take it that you can be sure that nothing else has changed in your LAN settings or firewalls? If anything else has changed, then look closely at that because MTU is just one possible cause.

  Kemistri 17:36 27 Jun 2008

Oh, and look at the Linksys firewall, too. Its packet filtering may be to blame.

  robgrayson 17:53 27 Jun 2008

You said:

With the Linksys in auto, see if 1500 is actually the right value or if it's misreporting for some reason. would I check that?



  Kemistri 20:52 27 Jun 2008

Compare the 1500 value that the Linksys has automatically generated and compare it to what your ISP recommends. I think the automatic detection usually works fine, but it may have defaulted. I believe that 1500 is one of the common defaults among modems and routers.

  ambra4 23:35 27 Jun 2008

Cyber Tweak

Download Cyber Tweak in the drop down menu select ASDL and click Optimise

click here

  damian212 11:17 03 Jul 2008

I had a similar problem. My laptop was connecting wirelessly at 2Meg but the PC connected by ethernet could only manage 100k.

In the end I had to reset the router to factory default settings and it fixed the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?