Broadband speeds

  LimestoneRock 10:59 16 Sep 2011

I had been using a standard Belkin, and then a D-Link, wireless ADSL router but because I had problems with connections breaking up I decided to invest in a new ADSL Router. This is a Belkin N+ wireless router. I was getting 3.5mb speed from the first two (in line with that projected by TalkTalk) but with the new router I am getting only 1.8mb. In checking in InSSIDer I notice that I had two channels, 11 & 7, and I went into the Belkin site to see if this could be amended. I can change by going manual but it still picks up a reserve channel. Hernce it is always showing the two channels being used in InSSIDer. I am assuming the reason the speed has virtually halved - 1.8mb against 3.5mb - is because of this two channel situation and would appreciate someone confirming my thoughts or adding others please. I have 3 computers in my home network and the other two show the same speed readings.

  mgmcc 13:08 18 Sep 2011

The first thing I'd suggest you check is the speed you're getting with a wired ethernet connection between router and computer. This will at least determine whether it is actually a wireless problem.

  LimestoneRock 15:03 18 Sep 2011

Many thanks for your response mgmcc and apologies for delay in replying. I have tried the wired set up and I get the same result - 1.786mb.

  mgmcc 17:08 18 Sep 2011

That would appear to rule out wireless issues and channel numbers. It might be worth getting in touch with Belkin's tech support people. It is many years since I had to contact them, but at the time I did find them very helpful and knowledgeable.

As my broadband is Virgin's Cable service, I cannot advise on ADSL issues.

  LimestoneRock 18:01 19 Sep 2011

Thanks again - I'll let you know, in due course, how I get on.

  LimestoneRock 16:21 24 Sep 2011

Still trying to sort this one out but it looks like, as suggested by mgmcc, that it is the Belkin Router. I have been in touch with their technical people by way of e-mail support and they are extremely helpful. Have downloaded two different firmwares but problem still not resolved although speed has increased now to approx 2100mb (still far short of the 3600mb I was getting previously) and I now have just the one SSID as opposed to two. I am still in communication with the Belkin support people.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?