boot.ini Win M.E. file needs redoing

  Hitman codename 47 17:39 22 Apr 2003
Locked

hi all

Had a dual boot system. Now have two hard drives instead.

So deleted XP off of the dual boot hard drive and put it on the new hard drive.

Problem is i forgot to set Win M.E. as the default boot system so now when the pc starts i have to select M.E. everytime as the XP option even though i can select it, doesnt exist any more.

Has anyone got a win M.E. alone system which they could access their boot.ini file and copy and paste it so I can put it into my boot.ini file and modify it.

To get to it go to Start - Run
then type

c:\boot.ini


Thanks in advance.

  Hitman codename 47 21:39 22 Apr 2003

can anyone help

  temp003 04:43 23 Apr 2003

Safety precautions first. (1) Save a copy of your existing boot.ini to a floppy. (2) Make a Windows ME startup floppy.

I assume you have Windows ME installed on the C drive.

Solely for the purpose of making ME the default OS, open boot.ini and change the line starting with "default", so that it reads:

default=C:
Save the changes and exit Notepad. Restart. This will work, since nothing has changed as far as ME is concerned.

******

However, it is not clear what you want to achieve ultimately.

If you want to use ME as the only OS, restart the computer with the ME startup floppy. At the A:> prompt, type sys C: and press Enter. You will get the message "system transferred". Remove floppy and restart. Computer will boot straight into ME. This does away the need for boot.ini, as ME as a single OS does not use it, as Beta noted above.

******

If you want to retain the dual boot with XP, but want XP to be on the 2nd hard drive, the safer way to do it would have been to install a fresh copy on to the 2nd hard drive (selecting a partition on the 2nd hard drive for installation during XP setup), and reinstall programs.

You seem to have simply moved the files on the old XP partiton on the 1st hdd to the 2nd hdd. Is that right? You cannot now boot into XP, because the path to the XP installation on boot.ini is now wrong.

Even if you correct the path for XP in boot.ini, there may still be problems, as the XP registry may contain references to drive letters or location of programs, which have now also changed. It may or may not work, depending on how the drive letters have changed.

If you have indeed taken the trouble of moving all the files (including hidden files) on the old XP partition to the new partition, you could try editing boot.ini just to see if you can boot into XP.

Assuming ME is on the C drive on the first IDE hdd (master), and the moved XP installation is now on the first partition on the 2nd IDE hdd (slave), the boot.ini file should read:

[boot loader]

timeout=8

default=C:
[operating systems]

C:\="Microsoft Windows Millennium Edition"

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

Note: (1) timeout value should be at least 5 if you want to have enough time to make a selection; (2) default OS is ME - this is the safe choice; (3) rdisk(1) refers to the 2nd IDE hdd

Save the changes and exit Notepad. Restart and select XP. See if you can boot into XP. If you can, test programs to see if they run properly.

If things don't work out, you can always boot into ME.

*******

Alternative, and safer way, is to install a fresh copy of XP to the 2nd hdd. Back up important data first. Boot up the computer with the XP CD, enter XP Setup and choose a partition on the 2nd hdd to install the fresh copy. If there are already XP files in that partition, remember to format the partition, with FAT32.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017