boot problem on adding 2nd harddrive

  OldNick 20:18 25 Dec 2005
Locked

I'm currently running a Dell Dim4100 933Mhz with Win ME. I want to install XP Pro but due to legacy software issues I want to do a dual-boot install so have bought a second HD (western dig Caviar 80GB)to go with the original 20GB HD. Since the original drive is 5 yrs old I've been advised to swap the HDs over and install the new XP Pro on the new HD, leaving Me on the old drive. I've inserted the new drive (both drives are jumped as 'cable select' in the usual Dell manner, but on rebooting I get a message saying non valid boot diskette. There is no floppy in the drive. Can anyone point me as to what to check first? I've tried the cables a few times - they seem OK. Any help appreciated - Nick

  Stuartli 20:22 25 Dec 2005

You need to change the Bios to Boot from CD as you are installing XP onto the new drive.

Before rebooting put the XP installation disk in the CD-ROM or whatever optical drive you are using.

  Fruit Bat /\0/\ 20:27 25 Dec 2005

I've been advised to swap the HDs over and install the new XP Pro on the new HD, leaving Me on the old drive. I've inserted the new drive (both drives are jumped as 'cable select' in the usual Dell manner, but on rebooting I get a message saying non valid boot diskette. There is no floppy in the drive.

No operating system found on your new hard drive.

Set the BIOS to boot from CD as first boot device (It may already be set this way)

Boot with the XP CD in the drive watch for the message "press any key to boot from CD"

and go into windows setup. It should find your drives and offer to format the new one, (make sure you do not format the drive / partition with ME on), format and instal XP.

  Sharpamatt 20:43 25 Dec 2005

unless I am mistaken many dells have the system restore to factory settings, hidden in the HD.so do not format that drive

So changing to secondary could itself cause problems ( Come on Dell experts )

Cable select is self explanatary so which connector on the cable did you connect each HD to.

  Stuartli 20:51 25 Dec 2005

This is a new hard drive that's involved.

  Stuartli 20:52 25 Dec 2005

If you temporarily disconnect the other drive then there's no danger of an incorrect installation.

  OldNick 09:43 26 Dec 2005

So if the old drive (now in the middle position on the cable) carries Me, and my new drive on the end of the cable (ie primary drive) is unformatted, the boot sequence won't check floppy, then primary HD then secondary HD, find Me on the second HD and boot from there? Does this mean a dual-boot setup with one OS on each HD is doomed to failure (ie if I get this PC working it'll only boot from whatever it finds on the primary HD?)

Nick

  rawprawn 10:01 26 Dec 2005

I am not sure on the dual boot position, but I would take the original HD out at this stage (Dell do have a hidden partition)Install XP on your new HD then install the old HD as Slave (Not cable select)I am not at home so won't be able to answer questions at the moment.

  Fruit Bat /\0/\ 11:46 26 Dec 2005

"the boot sequence won't check floppy, then primary HD then secondary HD, find Me on the second HD and boot from there? Does this mean a dual-boot setup with one OS on each HD is doomed to failure (ie if I get this PC working it'll only boot from whatever it finds on the primary HD?)"

You can set the BIOS to boot from EITHER primary or secondary HDD.

What you need is XP on primay drive with boot paths on the primary drive to the secondary drive (ME). This will give you the choice on start up of which system to boot into.

click here

  OldNick 20:03 29 Dec 2005

ah, thanks fruitbat, I didn't realise it was an 'either, or', I thought they would boot in sequence. How do I setup the boot path you describe?

  Fruit Bat /\0/\ 22:16 29 Dec 2005

Dual Boot
click here
for how to edit the Boot.ini file

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?