blank screen - no beeps - poss cmos battery?

  saldobs 16:13 25 Feb 2004
Locked

Hi - a friend's computer has not been used for ages. He has been given a digital camera and wants to use the comp again..! However, the screen is totally blank (I have tried 3 monitors using different cables etc) it says no connection.
Could it be the on-board video card or maybe the battery is dead as it has not been plugged in for months.
Also can I put in a video card and get rid of the onboard wiring?
Thanks in advance for anyone's help!

  brydonr 16:41 25 Feb 2004

The beeps you refer to is the system performing a POST test (Power On Self Test). Since you are not getting this I would check the PC itself is getting power i.e LEDs and fans operating, if not then either the PC power cable is faulty or the Power Supply has failed.

  Rennaissance 17:18 25 Feb 2004

i really dont think so. I would recommend getting another AGP graphics card and disable the onboard one in bios. Many cases have had this problem, but i haven't come across it being the power supply. It would either be faulty or not seated properly RAM or Graphics card, as you have onboard, i would suggest starting from there.

  saldobs 19:59 27 Feb 2004

Hi many thanks for your replies, however, I decided to try a new cmos battery as it is a cheap option at £2.99!
Thankfully, I put it in and the screen came up good as new!
So it is worth remembering, a simple thing like a battery has saved my friend about £40 for a graphics card.
For future ref, how do I disable the onboard card should I want to?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?