Black Screen - Can't Run Explorer.exe With Task Manager

  VietDam 02:13 17 Jan 2014
Locked
Answered

Hi guys

I have been Googling the answer to this for the last day and nothing has seemed to work.

Basically, my laptop was working fine until this morning, when I restarted it. After the Welcome screen, just a back screen with the mouse. CTRL ALT DEL and all that still work normally. I can run programs with Task Manager but can't run explorer.exe. It comes up in the Processes for about 10 sec then disappears. I believe this is the cause for the black screen. I have tried downloading a clean explorer.exe and replace the explorer.exe in C:\Windows. My computer didn't allow it as it said I need administrator's permission but of course I'm the administrator so I don't know what that's about. I tried rebooting in Safe Mode and that works fine, still I can't replace the explorer.exe in the C:\Windows\ because I don't have administrative permission. I tried to change it in the Security tab in Properties, couldn't either. I have also tried to Update Driver Software of the Display Adapters, checked the Shell value in the registry and made sure it was explorer.exe, used the Black Screen Fix from Pevx, used HitmanPro and Windows Malicious Software Removal Tool to scan and delete malwares. I even did a scf /scannow, checked driver C for error (which took 3hrs!!!), let Windows StartUp Repairs sort things out, attempted a System Restore but failed. It said the antivirus (Sophos) was preventing the system restore so I temporarily disabled its on access scanning but still can't restore to an earlier point (11/01). The only recent program changes as listed in the system restore is Google+ Auto BackUp which came when Picasa updated 3 days ago and a newer version of Facebook Video Calling which I never used. I'm now running a scan with Sophos, not too promising. So yeah, I have tried everything. I think there's only three options now:

  1. Somehow replace the explorer.exe in C:\Windows\ with this new fresh explorer.exe I downloaded, with an administrator's permission
  2. Attempt another System Restore but I'm sure nothing will happen again, already tried three times.
  3. Reinstalling Windows 7 Home Premium. This will be a real pain.

So PLEASE HELP ME!!! I have coursework to hand in on Monday and this laptop is not letting me doing anything. THANK YOU!!!

  VietDam 06:20 17 Jan 2014

Thank you for replying. I have tried both methods and didnt get a result. Explorer.exe wasn't in Task Manager unless I run it and then it only appears for 10 sec as mentioned, then closes itself down. Sfc can returned with nothing's wrong, even though during the scan there was a pop up saying "Windows Explorer is not responding" or something similar.

  VietDam 11:53 17 Jan 2014

I have run CCleaner and MalwareBytes for the full system so there shouldn't be any left over, unless it's that persistent in which case I'm planning on using this bootable rescue cd from Kaspersky. The corrupt user account might be a good suggestion actually. I might try that now to see what happens. Thing is, will I be able to make this new account administrator? And then the problem of transferring files and programs over. Urgh, why can't technology make sense. Thank you nevertheless :)

  VietDam 23:26 17 Jan 2014
Answer

Thank you for replying.

After trying all sort of scannings, drinking and sobbing, I came across TDSS Killer from Kaspersky which managed to catch 1 last single malware (which I was too stupid and hopeless to actually looked at and remember the name of), it cured the problem after rebooting. The laptop is now running fine like you wouldn't believe. I'm still baffled but way too overjoyed now to care. Thank you for your help nevertheless!

  VietDam 11:51 18 Jan 2014

Yeah thank you I'll look into that. It was indeed a rootkit if I remember correctly. Damn these craps!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017