BIOS Update Problem

  Manic Noise 21:10 08 Dec 2003


I've just been trying to add a 2nd hard drive (Maxtor 80gb) to my PC.

I bought the PC in 1999 from Tiny (Yes I know!)and I got the impression from a bit of reading that I would first need to update the BIOS especially with a drive of that size.
The motherboard is a Microstar MS6183 and the bios was v1.3

I updated it to v1.7 as that was the highest download version I could find on the net, from a (or something like that) website.

Since then whenever I go into CMOS --> Auto detect for the Hard drives, the screen freezes, and shows about just over 9000 cylinders or blocks (can't remember which) for the 2nd drive, which is less than my primary 17gb drive.

Also one of the kids maths programs now crashes.

Have I just downloaded the wrong version?
Any ideas on fixing this would be greatly appreciated.

Many Thanks.

  LastChip 22:09 08 Dec 2003

Did you clear the CMOS (BIOS) after you flashed it?

This is normally done by a jumper on the motherboard. Alternatively, take the battery out for five minutes or so!

  Manic Noise 23:49 08 Dec 2003

Thanks for your reply.

No, I hadn't cleared the CMOS. Actually, I didn't even know you had to. I'm kind of learning this as I go - and sometimes you learn the hard way!

Anyway, here's what happened when I did it and booted up the PC.

The memory started counting up on the top left of the screen and once it had finished I got this message....

'CMOS/GPNV Checksum Bad'

Press F1 to run Setup
Press F2 to load default values and continue.

First I tried F1 and it went into the CMOS screen which I decided was not what I wanted so I exited, and it started asking for boot disk.

Anyway, I rebooted and chose F2 instead.
Windows 98 started up, and it looked like it was redetecting hardware. It said that it had found a new PCI card, and then wanted drivers which it couldn't find on the C drive.
My mouse wouldn't even work.

After a reboot everything seemed back to how it was before clearing the CMOS, with the autodetect for the hard drive still frozen.

I've no idea what that message was, but I guess Checksum Bad can't be good.

Any ideas anyone??

Thanks in advance!

  LastChip 21:30 09 Dec 2003

and then on bootup, when you get the message; [Press F1 to run Setup Press F2 to load default values and continue];

Press F1 to go into SETUP, and then press F10 (to Save and Exit). This will align the CMOS map for the currently installed BIOS.

Make sure your processor speed is correctly identified.

As far as I can see, you do have the correct BIOS version, so that shouldn't be an issue.

  Manic Noise 00:51 11 Dec 2003

Thanks for you reply again.

I tried what you suggested but unfortunately it didn't do the trick.

But here's the story...I did a bit more experimenting and had just finished tapping out an almighty reply with loads of what
I'd tried and the results when I wondered if it could have been a problem with the jumpers.

The excuse bit....The drive I bought wasn't what someone described to me as "a retail kit" i.e. didn't come in a nice box, with a manual, CD, cable etc.
I bought it from a shop (don't get me wrong - a good shop as far as I'm aware) that sells the whole range of computer components, but it came in its anti-static bag in bubble wrap but no box, CD, manual etc.

On the writing on the Hard Drive itself it said "No Jumper=DS(Slave)"
I'm no expert on these things but I took that to mean have No Jumper as I want this to be the Slave.

Anyway, tonight I downloaded the manual for this drive from Maxtor's site, and it mentioned something about a Cylinder Limitation Jumper for use in case of a BIOS Capacity Barrier.

I set the Cylinder Limitation Jumper and hey-presto!! Auto detect works without hanging.
It actually has a troubleshooting section in this manual describing this very behaviour.
I'm guessing that the answer as to why it was hanging is that the BIOS is struggling with the size of the drive.

So I now have this in the CMOS....
Type Size Cyln Head .....etc
---- ----- ----- ----
Pri Master User 17082 33096 16
Pri Slave User 33822 65531 16

I think this means that Auto Detect has currently limited it to around 34GB courtesy of the Cylinder Limitation Jumper, but without that I'm being hindered by a BIOS limitation.

Maybe tomorrow if I remove the Cylinder Limitation Jumper, and try putting in a higher Cylinder number manually from the Standard CMOS screen I'll be able to increase on the 34gig, but the input field won't allow more than 5 chars for the number so I still don't think I'll get the full drive.

Going by the figures above I reckon I'd need to be entering a number of cylinders around the 140,000 mark for my 80gig drive.

At the moment it won't let me manually go above 65535 Cylinders which might be because of the limitation jumper, but I'm not 100% confident as obviously 65535 significant as the highest double-byte number, so it might be the limit for this BIOS anyway. I'll find out tomorrow.

The short release notes that came with the BIOS download said...
"This BIOS fixed the following problems of the previous version: - Support Maxtor 40GB HDD"

I think I wrongly took this to mean that it would support 40GB and higher.

Given that this MOBO is no longer manufactured and I think this v.17 BIOS was last updated in 1999, then the chances are that it'll never support a drive of this size, and I'll probably need a new board (plus CPU while I'm at it!).

I'm still going to do a bit more reading up, experimenting, and research on this in case I've missed something.
That's a bit long winded but if anyone stuck with it does it sound reasonable?

Thanks again for your help.

  LastChip 01:35 11 Dec 2003

If that's the route cause of your problem, why not download Maxtors Max Blast?

This is a "layering" program, that overcomes the size limitations of older BIOS's.

It's self explanatory, faster (and simpler) than fdisk to use.

Once you have "made your floppy" with the program on, Reset the jumper on the drive to master or slave as required and then boot-up with the floppy and let it do the work!

The floppy is bootable, so if you temporarily disconnect your existing drive, there will be no possibility of accidentally formatting the wrong drive. Partition and format to taste. When complete, plug in your existing drive and your new drive will automatically appear in Windows!

  Tick Tock 23:41 11 Dec 2003

i have the same version bios as you have but
reading instuctions it says om the MSI website
that you have to update the version that matches
your system, ie MS6183 V1.3 is this right.

  Manic Noise 14:54 12 Dec 2003

Last Chip,

Thanks, that's great - I'll look into that as well then.

I had noticed that program mentioned on Maxtor's site.

I haven't had a chance to read up on it yet but I've had a quick look at the overview and as you say it lists breaking the capacity barriers amongst the features.

An extra hurdle on this is that I'm actually wanting to make the PC dual boot, with XP on the second drive. So I need to look at the issues
surrounding the dual boot installation of XP on existing Win98 and where/if MaxBlast would fit in with that scenario, especially with such things as
Win 98 not being able to read NTFS. Don't know if that'll come into it or not.
But as I was expecting the 2nd drive to be an NTFS partition, rightly or wrongly I wasn't expecting it to be visible to Windows 98 anyway.

I really get the feeling I'm jumping into a snakepit, but it'll be interesting to find out. I can see further posts brewing.

I haven't had a chance to get back to trying any of this yet but hopefully today or tomorrow.

I'll post back my results on Maxblast once I've got to that stage, in case you or anyone else is interested.

Thanks again.


Tick Tock,

When you say you have the same version of the BIOS I'm assuming you mean you have v1.7 as I now do.

Take a look at this link.....

click here

This seems to be the BIOS for MS6183 and it has the latest as v1.7.
I only found it today. I actually downloaded v1.7 from a different site (see 1st post) and I think normally I'd be tempted to download and install this version now instead, however the file name and size match so I don't think I have a problem.

Also, when you say "matches your system" you're talking about the motherboard?
If, so I'd agree, but looking at the link above it does seem like v1.7 is the latest and quite probably the last so in my non-expert opinion I'd say v1.7 is the one to have.

LastChip - you're obviously more clued up on this - maybe you could comment?

  Tick Tock 19:36 12 Dec 2003

Just read the link yes v1.7 seems the latest
i have still got MS6183 V1.3 but will now think
about updating.

  LastChip 22:55 12 Dec 2003

If you look carefully at the BIOS's on the page, you will see the top one relates to the AWARD BIOS, all the others to AMI.

When BIOS code is written, successive versions incorporate all previous changes, so as a general rule, it is wise to use the most recent version.

If Tick Tock and your good self had version 1.3, then it must have been an AMI BIOS, as it appears the AWARD version has not been updated.

All BIOS "flashes" MUST be treated with the utmost respect. One wrong move, and you have an unserviceable motherboard, therefore, unless you have a very good reason to flash a BIOS, leave well alone!

As regards your dual boot, it should not be a problem, but it is important that XP is installed after '98 and it will then give you the option to leave your existing system in place. You may also need to install XP in conjunction with Max Blast (see the FAQ's at Maxtor - look for installing 2000/XP).

When you boot-up, you will get a screen offering you the choice of which system to boot into. The default can be set for either, within XP.

  Tick Tock 23:28 12 Dec 2003

Think i will leave alone at present.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?