BIOS sticks on logo screen

  teka1722 09:54 07 Aug 2013
Locked

My 5 year old packard Bell desktop does following when switching on by pressing the on button

  • slight noise and 1 bleep
  • monitor screen display shows the PB logo and legend "F2 for Bios setup" etc
  • after 10 minutes the window software loading bar is shown

Windows appears to work normally once working

The delay appears to me to be in the BIOS and nothing to do with windows - is that correct?

The BIOS use to display message about memory test and drives - now nothing is shon between the olgo and windows starting

help please with determining the problem

  Chronos the 2nd 10:10 07 Aug 2013

This could be caused by any number of things, keyboard and or mouse. Try another KB/Mouse. Power supply unit could be failing. These PC's use a very cheap PSU and will fail fairly easily, so could try another PSU. It could be a motherboard problem, which would mean, a new PC,probably. Could be a memory (RAM) issue.

Some things to try:

Power off, pull out power cable and the CMOS battery for 5 minutes, or short across the battery contacts.

Try with only one RAM stick in and see if it loads quicker.

Disconnect all drives except the OS, all USB devices except keyboard, mouse. In fact disconnect the kybrd and mouse too since we are testing to see if it loads quicker.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse's new logo: the trainer brand looks to its heritage for a fresh identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?