BIOS ROM checksum error

  DavidM4 18:47 28 Jan 2008
Locked

My mate is having trouble with his Advent T9100.

When we turn it on we get just a black screen with the text,

Award BootBlock BIOS v1.0
Copyright(c) 2000, Award Software, Inc.
BIOS ROM checksum error
Detecting floppy drive A media
INSERT DISK AND PRESS ENTER

We've tried his system recovery disk and my XP disk but nothing.

I've also tried accessing BIOS but It won't let me, any ideas are much appreciated.

  birdface 18:52 28 Jan 2008

Looks like the battery may be knackered.Was it loosing time and date just before the problem.

  birdface 18:57 28 Jan 2008

Might be this.click here

  Quiller. 18:59 28 Jan 2008

Has it got a floppy disk drive?

Has it got a disk in it?

  DavidM4 19:02 28 Jan 2008

Yeah it has a floppy drive but there is no disk in it.

Just phoned him and he's gonna try a new battery.

  Quiller. 19:08 28 Jan 2008

Why won't it let access the bios, is it password protected?

If it is, it's not a battery problem.

  DavidM4 19:33 28 Jan 2008

It is going straight to the error screen when booting and pressing f8.

  Quiller. 20:30 28 Jan 2008

F8 is for boot options, like safe mode.

pressing the delete key as it starts is the way to get into the bios.

  DavidM4 20:38 28 Jan 2008

Sorry yeah I've tried both and nothing.

  DieSse 21:24 28 Jan 2008

It might be the F2 key also.

Whichever it is, you need to tap it continuously as the system starts to boot (not hold it down, just keep tapping it.)

  Zeppelyn 23:55 28 Jan 2008

The reason its asking for a disk is some motherboard makers give you a floppy or cd with a bios recovery on it (asus for example). You insert the disk/cd and the bios is recovered, I think thats what the message is referring to. You could also try removing the battery for a min then reinserting and see if that does the trick.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Is this the future of VR and AR?

Best iPad buying guide 2017

Comment regarder le Bureau des L├ęgendes en ligne ?