BIOS not detecting primary master drive

  bobfan 11:19 02 Jan 2006
Locked

Hi
I have PC I use for work & recently have been having the following problem.
When I boot up it searches for the primary master drive but comes up as none & then wants to boot up from a floppy. If I go into BIOS setup it will find the drive, I press F10 to save the changes & boot again but still does not find the drive. Often if I keep trying it will eventually find the drive & boot up, then all works fine. I was advised to change the battery on the motherboard which I have done but it has made no difference.
Any help would be much appreciated!

OS- Windows XP - SP2
1400 AMD Athlon
Board- ASUS A7A266 1.10 socket A
1024 MG RAM
HD – Fujitsu 40G

  Diodorus Siculus 12:03 02 Jan 2006

There was a case of those fujitsu 40gb disks causing trouble and going by your processor speed, I'd think that it could be from about that time (mid 2001?).

Getting a new hard drive would be one option - then use the current one for backup purposes.

  malgall 12:10 02 Jan 2006

i had the same problem in that it would sometimes
detect hard drive but sometimes not
on this forum i was told that sometimes a computer can boot up so quickly that your hard drive is not ready
so in bios switch on memory check if there
also tell bios to floppy seek and put the floppy
drive as first boot and hard drive as second

this solved my problem

  bobfan 13:55 02 Jan 2006

So I have just tried the PC to check malgall suggestions & guess what it boots up first time!
I'm not sure if the memory check is on but I do know that the floppy is first. Is there anything I can check through Windows?

Diodorus Siculus thanks for your reply, I did think about the hard drive, but why does it work sometimes??& yes you are right mid 2001 I got the PC, hence its now just used for work!

Thanks again

  DieSse 14:13 02 Jan 2006

As drives get older, sometimes they take longer to get completeñy up to speed and become ready (ie available). This can then on occasions exceed the time it takes for the booting to look for the drive - so it doesn't find it. That's why the solution is often to make the initial part of the boot take longer, by enabling the longer memory test, and/or making the system look for the floppy drive first. Some BIOS even have a facility to put in a delay before the hard disk is checked.

  bobfan 16:35 02 Jan 2006

PC has been running fine for a couple of hours or so now so I thought I'd do a restart & guess what the HD is not found, although it is in the BIOS setup!

DieSse
Here's the options I have in my BIOS setup.
Plug & play OS - no
Reset configuration data - no
boot virus detection - enabled
Quick power on self test - enabled
boot up floppy seek - enabled

These are all the default settings.

  DieSse 16:42 02 Jan 2006

Change the *quick power on test* to disabled - this gives a longer test (ie it disables the quick one, and runs the regular - slower- one).

See if this helps.

  Fingees 16:54 02 Jan 2006

If you are running XP plug & play OS should be set to yes.

Not that this will be cause of the the problem.

  bobfan 17:18 02 Jan 2006

That seems to have worked! Although the memory test appears to go on a loop until I tell it to skip, but I do get asked what drive I want to boot from & the HD was found! Does this all point to a problem with the HD & would a new drive solve the problem completely?
Thanks Fingees I thought on XP it should be set to yes, old PC! As you say not the cause on the problem!

  DieSse 17:24 02 Jan 2006

It probably isn't in a loop - it generally runs through the memory some 3 times or so - so just leave it and it should finish.

Yes it is a sign that the hard drive is playing up - though they can last a long time in this state. Whether you risk it or get a new one is down to the usual reasons.

  bobfan 17:34 02 Jan 2006

Thanks DieSse I'm now busy backing up all the data! Think I will probably just replace the drive. I don't need a large HD on this PC, 40G is more than enough so for the cost involved not worth taking a risk. I just didn't want to replace the drive if this wasn’t the problem!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?