BIOS does not recognise IDE CD and DVD drives

  User-519324 14:36 20 Dec 2007
Locked

This problem is very strange, not something I've seen before. I'm trying to fix a friends computer (including reinstall of XP) as he's had problems - including not being able to see his CD and DVD drives in XP.

I rebooted to check what was going on in the BIOS but neither were recognised in the BIOS. I disconnected both, and tried them (one at a time) on IDE1 Slave, then IDE2 Master then IDE2 Slave (with the correct jumper settings), but neither drive is recognised. Also tried the same with HDD disconnected but the CD drives do not show up. (NB HDD shows up on either IDE channel, regardless of whether optical drive(s) connected)

However, when trying to boot from CDRW drive into liveboot Linux or Windows Install CD it works (not tried DVD drive as have no bootable DVD).

Is the lack of recognition in the BIOS a problem and is there a way to fix it? I've not seen apparently 'working' drives that are not detected by the BIOS - is the drive / MB IDE controller / BIOS settings likely to be at fault. Both IDE controllers set to auto in BIOS and autodetect fails to find either drive.

Any suggestions?
Thanks in advance.

  ambra4 16:52 20 Dec 2007

Have you replace the IDE cable??

  Fruit Bat /\0/\ 17:09 20 Dec 2007

Try this if the optical drives are not appearing in My Computer or Device Manager.
(This is sometimes caused by the removal of Roxio or other writing software.)
click here
Download XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect.
This utility is only intended for Windows® XP, but also appears to work for Vista.
You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

or
Run regedit and navigate to registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}.
Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.
Highlight each one in turn, right click and delete them.
Close regedit and restart the computer.
If in doubt make a restore point before making changes.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires