Belkin wireless router problem

  richierich 20:06 23 Dec 2005

Desktop connected through ethernet cable to router which is connected to phoneline/ internet.
laptop has a wireless card which connects wirelessly to router and internet. been working fine for about 7 months.
suddenley the desktop wont connect to internet, it says the network cable is unplugged (its not) or the status has 'limited or no connectivity' but the laptop connect wirelessly ok.
the motherboard has on board LAN, is it likely this is faulty. by the way the pc connects fine via a usb adsl modem

  ajm 22:26 23 Dec 2005

Could it be possible that the lan card on the PC has been accidently been disabled. have a look at this link click here

  richierich 08:47 24 Dec 2005

No, the icon is enabled, itried disabling and enabling again, noluck. I also tried the repair option but after a time it says it failed to obtain new ip address.
the actual lan card is built into the motherboard.
im wondering whether i should try a slot in one.

  mgmcc 09:32 24 Dec 2005

You haven't by any chance moved the router or touched anything at the back? One of the LAN ports will be an "Uplink port" with a button to change it for use when "uplinking" to an additional network switch.

The effect of this button is the same as changing from a "straight-wired" to a "crossover" network cable and the wrong cable configuration would give a "Network Cable Unplugged" indication.

Another possibility is that you have actually been using a "crossover" cable with the port in "Uplink" mode, in which case plugging into a different LAN port wouldn't work.

The "Limited or No Connectivity" is normally due to being unable to acquire an IP address from the router. Instead, Windows allocates a "169.254.x.x" address with which you won't connect to the router. "Repairing" the connection would normally force a renewal of the IP address but this hasn't worked because the network adapter hasn't found the router's DHCP server. If the "wireless" adapter in the other PC is using a *fixed* IP address, check using that PC in the Belkin's Setup pages that DHCP is still enabled. (If the "wireless" adapter is getting its address automatically, DHCP must already be working.)

  richierich 09:45 24 Dec 2005

there are no buttons on the back of the router,pretty certain apart from a reset one (which i have tried) and the cable is the only one ive been using for the past 7 mnths which worked fine.
iwill try your suggestion about the DHCP using the laptop when i get home from work today (yeah sad working on christmas eve) and report back.
meanwhile thanks for all help and have a good christmas.

  igk 14:25 24 Dec 2005

Go into "Services" and find "Wireless Zero Configuration" Stop it if its running then disable it..
this service is a pain in the *rse as it tries to override belkins (and other makers) own networking software..
do this on all pc's...
Hope this helps..

  mgmcc 15:53 24 Dec 2005

As I understand it, richierich's problem is with a *wired* ethernet connection, the laptop's wireless connection is OK.

  richierich 16:51 24 Dec 2005

DHCP was working, iwent to setup pages using wireless laptop, then i foolishly went for return to factory default settings now i cant get onto the setup page again, HELP

  richierich 16:53 24 Dec 2005

just to add my usb modem works ok and yet the icon says limited or no connectivity

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017