Belkin Wireless Modem Router very slow

  jul2007 14:59 16 Jul 2007

Does anyone have any experience of the BELKIN F5D7633UK4A (108Mbps Modem Router) + Belkin Wireless Network card? We purchased them yesterday from PC World. Connected it up and configured it OK for a Vista Desktop PC and can connect to the internet via wireless, but it is extremely slow. In fact so slow opening up webpages that we've plugged the cabled modem back in for now.

Any feedback on whether we can improve the speed would be great otherwise I think we'll be taking it back to the shop.



  X™ 15:46 16 Jul 2007

Hmm reset the wireless. Is the wireless itself slow, or just the internet? Sorry about the slow reply.

  jul2007 22:13 16 Jul 2007

We've rebooted the router but this made no difference. I'm not quite sure what you mean by is the wireless slow or the internet slow,sorry. When on the internet via the wireless, bringing up various websites is very slow. If we then unplug the wireless and set up the ADSL modem using the ethernet cable to connect to the PC, then bringing up the same websites is much much faster. We also found that when we had a laptop plugged in to the router with an ethernet cable the internet was also still slow. There aren't that many configuration settings that can be made on the router to play around with, so we're not sure what to try.

  quazi 17:26 18 Jul 2007

I just dropped the solution to this in another thread but to save you from looking arround do the following:

Select "my computer" then "properties". select the Device Manager button under the Hardware Tab. Select your network card from the list (should located under network adapters) right click and select properties and under the Advanced tab look for Speed & duplex in the box. select it and change the drop down menu from Auto to 10mb/half duplex. This should clear things up.

Atleast it did for me, and by your description we had very similar issues.

Good luck

  quazi 22:03 18 Jul 2007

Sorry just realized your issue was with the wireless card not the router. Although the card should also have a tranfer rate buffer that you can change the settings on. So in a round about way this might still help you.

  ranny528 16:44 24 Sep 2007

hi all it sounds like you are having the same problem as me. with my original modem i downloaded some updates with speeds reaching 400kpbs but with this belkin snail router it wouldn't even reach 1 kbps. i have tried it wireless and tried it via ethernet and even both at the same time but nothing, All i do now is when my son come off the internet with his laptop which is also slow i plug my old modem back in. i have tried the above with no difference. If you do find the solution please post as i am on the verge of going back to royal mail as it seems quicker. many thanks ranny

  ranny528 16:52 24 Sep 2007

sorry just download an update for my firewall with speeds reaching 695KBPS on my old modem with the belkin sorry i have to go to work in 14 hours time so will not have finished in time (200bps).
THERE HAS GOT TO BE SOMETHING WITH THIS MODEM/ROUTER and it is the second one as i thought the first to be faulty.
In a sad kinda way i feel half glad that someone else has this issue.

  ambra4 11:58 29 Sep 2007

How to fix Vista's network bottlenecks

The problem with Vista's new-fangled network stack

All this automatic tuning of the Vista network stack sounds great in theory

But the problem is that some clients don’t support TCP window scaling

Or don’t have it enabled.

Additionally, some firewall products also don’t support it.

In either scenario, the result is dropped packets, which affects network performance horrendously

Your traffic is literally dropping into a black hole, never to be seen again.

If you’re experiencing excessive network lags on Vista

If using McAffee uninstall and turn off IPV6

Do this opening up an Administrative Command Window

Right-click-Run as Administrator and type in the following command:

netsh interface tcp set global autotuninglevel=disabled

You may also need to type in:

netsh interface tcp set global rss=disabled

The changes take effect straight away, with no reboot needed.

You can also check this site

click here

  ranny528 15:40 30 Sep 2007

i had the same problem as you i had tried everything but no luck. just exchanged it for a netgear modem/router followed install which was really easy and wey hey full speed wireless internet. i wont go near belkin again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?