Belkin Wireless G USB Network Adapter

  daz03 21:49 10 Feb 2006


I setup a wireless connection yesterday using a belkin F5D&632 wireless router and a Belkin Wireless G USB Network Adapter. It all worked fine yetserday and I had no problems with wireless connection.

When I restarted my pc today the wireless connection was gone - I tried reinstalling the wireless network adapter and now when I plug it in I get message that "USB Device not recognised." it then says windows does not recognise it and the usb device has malfunctioned.

Does anyone have any suggestions?

many thanks

  ade.h 22:38 10 Feb 2006

Did you uninstall the entries, driver and software for the USB device before you tried to install it again?

  daz03 22:47 10 Feb 2006

I think so. I used uninstall option on disc that came with adapter.

  ade.h 22:59 10 Feb 2006

Then all that you did was remove the software - and then, you are reliant on the quality of that program's uninstall routine to do a thorough job.

What you needed to do was then remove the hardware from Device Manager.

I'm not suggesting that this is the cause of your problem, but it certainly won't help the install process if it's still fully or partially installed at the time.

Another point about USB adapters; some people find that they run better without the software - driver only - and let Windows handle it. You could try that; remove the device properly and install it using only the New Hardware Found wizard. When it asks for a driver, point it to the CD or perhaps copy the driver to a folder on the PC ready for use.

See if that improves things.

  daz03 23:14 10 Feb 2006

When I plug in the adapter nothing happens now. It does not even attempt to recognise it as new hardware. Do you think the adapter itself could be faulty?

  daz03 18:45 12 Feb 2006

still no luck. wonder if anyone has any suggestions?


  ade.h 19:59 12 Feb 2006

If it is not being recognised as new hardware, then it has definitely not been fully uninstalled from your PC. Because it's USB-based, it can require more than just deleting its entry in Dev Manager.

For example; I sometimes use a 3G PC card which functions as a modem. Although it works now, it didn't initially and the only way to uninstall it fully was to uninstall the USB host controllers, which the PC card slot runs from. Rebooting the laptop allowed the USB host controllers to be automatically re-installed and the PC card would then finally be recognised as a new piece of hardware.

Try this technique with any USB device which fails to install properly.

  keewaa 11:32 13 Feb 2006

I also suggest you use the driver on the Belkin web site incase the CD is an old or problematic version.

  daz03 17:44 15 Feb 2006

Thanks for that help. I tried all of that to no avail. Finally been contacted by suppport site who say USB adapter has malfunctioned and to return it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?